404 error after installing Mautic 3

I have the same issue and I don’t have htaccess file. Can I find it somewhere to be sure I upload a correct one?

Here’s the .htaccess which ships with Mautic: mautic/.htaccess at a8558843c4cc9c9fe25df00803ea735f7f0100fc · mautic/mautic · GitHub

I cannot access backend interface. Our url is: https://mkt.montymarq.es
Should I see something at the config.php?

Hi Ruth,
Thanks I manage to make it work with your suggestions. Problem was htaccess. Now it is working fine. Thanks so much.

1 Like

Great, I branched this out to be its own topic so to not confuse folk!

Hi Ruth,

I think I want to append myself to this thread because I got the same problem.

The situation is I got a 404 error after the installation and then followed your advice to change the AllowOverwride Directive from “None” to “All” for the folder. This helped me to get rid of the 404 error after the installation but now every call I do to Mautic gets an “index.php” in between and with that failes.
Like this: “<…>/mautic/index.php” becomes a “<…>/index.php/mautic/index.php” and failes.

I also followed your advice and checked the .httaccess file you have linked and I can confirm that htis file does already exist in my local installation (with the same content :-)).

Do you have any idea what I can do?

The mautic folder is currently located in /var/www/html/mautic so next to the apache2 standard index.html file. So I think this should do it. I got two AllowOverwrite Directives which point to /var/www/html and /var/www/html/mautic (just in case…) and both are set to All.

Also the file config/local.php does not show the index.php (as asked in the other thread). It is only <…>/mautic.

Ok, I have shifted the mautic folder from /var/www/html/mautic to /var/www/mautic. Then I deleted the original html folder and renamed the mautic folder to html instead.
This did the job. Aparently the redirecting had problems with the fact that matic was a subfolder of html instead to be on this location.

@Ruth: Maybe you can confirm if this is really an issue?
In any case the problem is solved for me, too :slight_smile:

I have similar problem = after installing 404 error. I already took steps as above. No success

I have Mautic installed in folder /var/www/html/mautic and CANNOT move it to another folder (server owner security policy…)

does .htacces need to modified any other way to fix it?
any other idea what to modify so that it workes?

********* UPDATE *************

AllowOverride All solved the problem.


@vivasc i getting same error. Can ypu please help me on that. What you have done and where you have changed?