Mautic Community Forums

Asset Upload Problem

Hi,



I’m hoping that someone can help me out.

I have a self hosted Mautic installation 1.2.4 on Ubuntu 14.04.

I would like to increase the size of the Asset uploads for the purpose of making downloadable content available after a visitor completes a lead capture form. If I understand Mautic’s use cases correctly, this is possible, yes?



In any case, I have modified the following three parameters in PHP.

  1. upload_max_filesize 300M
  2. post_max_size 300M
  3. max_execution_time 600



    I have also changed the Asset max upload size parameter in the Mautic Configuration area to 300 MB.

    I know this seems large to some, but it is my use case, and I am not trying to send this via email.



    The current condition is that Mautic shows a max file upload size of 128MB in the Assets upload page, and when I attempt to upload a zip file of only 57MB, I get the following error after what seems like a successful data transfer.



    Upload a file (max filesize allowed = 128 MB)

413 Request Entity Too Large

413 Request Entity Too Large



nginx/1.1.19









Is the 128MB value a hard coded value, and if not where is it coming from since PHP should be configured to accept larger uploads? Secondly and most importantly, why are smaller files such as I explained above not successfully being uploaded?

Regards;

Hopeful New Mautic User
Mike

Hi,

I’m hoping that someone can help me out.
I have a self hosted Mautic installation 1.2.4 on Ubuntu 14.04.
I would like to increase the size of the Asset uploads for the purpose of making downloadable content available after a visitor completes a lead capture form. If I understand Mautic’s use cases correctly, this is possible, yes?

In any case, I have modified the following three parameters in PHP.

  1. upload_max_filesize 300M
  2. post_max_size 300M
  3. max_execution_time 600

I have also changed the Asset max upload size parameter in the Mautic Configuration area to 300 MB.
I know this seems large to some, but it is my use case, and I am not trying to send this via email.

The current condition is that Mautic shows a max file upload size of 128MB in the Assets upload page, and when I attempt to upload a zip file of only 57MB, I get the following error after what seems like a successful data transfer.

Upload a file (max filesize allowed = 128 MB)

413 Request Entity Too Large

413 Request Entity Too Large


nginx/1.1.19

Is the 128MB value a hard coded value, and if not where is it coming from since PHP should be configured to accept larger uploads? Secondly and most importantly, why are smaller files such as I explained above not successfully being uploaded?

Regards;

Hopeful New Mautic User
Mike

Make sure you’ve restarted server after the php.ini change.

The max asset upload file size is configurable in the Mautic’s configuration so check what limit is there.

As described in first post, I have changed “max asset upload file size” to 300MB in Mautic Configuration.
I have also made the appropriate changes in php.ini on the hosting server. Still I get this error with files that are substancially smaller than 300MB.

Thank You;

RESOLVED

This was an environmental issue and not a Mautic Problem.
My Mautic instance sits behind an Nginx webserver configured as an internal reverse proxy. This allows me to host websites on many different domains behind a single public IP address.
Nginx was incorrectly configured for my use case as it was set to only allow 50MB client uploads [client_max_body_size].

Probably won’t be useful for most people, but thought I would share anyway.