Broken Gravatar image

Your software
My Mautic version is: 4.3.1
My PHP version is: 7.4
My Database type and version is: MySQL 5+

Your problem
My problem is: Gravatar image is broken.

These errors are showing in the log: No errors shown in log

This is a brand new fresh installed Mautic and one thing I spotted right off the bat when I first logged in is that Gravatar default image is broken. I added a contact which have the image on Gravatar and it does pull the image fine.

I did a search on this forum and I notice some folks did have issue but I tried all their fixes and it still show broken for me.

Ports 80/443 and IP address shows open on my firewall
Local config and web site address in configuration setting show the correct website address.

What causing it to be broken?

Here the URL of the broken image on deafcoder.com.

It’s my testing ground so I am not worrying about it broken but I wanted to troubleshoot it and find the solution to fix it in case I face similar issue on production sites.

https://www.gravatar.com/avatar/b2abe0e4b9789137b6c7f623415b30d1?s=250&d=https%3A%2F%2Fdeafcoder.com%2Fmedia%2Fimages%2Favatar.png%3Fv952c18f0

Thank you

Hi,

it looks to me like you do not allow access to your media folder:

https://deafcoder.com/media/images/avatar.png

double check your permissions and web server config.

Also clear cache with: rm -rf var/cache/dev/* var/cache/prod/*

and try again

That folder is empty … Were there supposed to be avatar.png?

I do have Mautic in production on a different shared hosting and that the file exist on it so I copied over the avatar.png over. I noticed it missing all the image files in that folder when compared to images files on github.

This was a composer installed Mautic and I am wondering why it didn’t add those images files… Any idea?

Do composer keep log of installation that i can review? I can just delete the whole thing and start over to see where the problem occurred.

Hi @techbill ,

Image is in repository:

I see however that its not in composer based install (at least not mine), download the image from repository, problem solved.

Yeah, I figured it broke in 4.3.1 since my composer based install mautic 4.2.1 have the images in this folder.

I reported the issue on github.

1 Like