Campaign - Action "Add Points" result in error and campaign execution stop

Your software
My Mautic version is: 4.4.11 (classing installation, not with composer)
My PHP version is: 7.4.33
My Database type and version is: 10.11.4-MariaDB-1~deb12u1

Your problem
My problem is:

The Action “Add Points” in any Campain results in an error in the logs and any further actions are not executed anymore.

These errors are showing in the log:

[2024-02-28 22:37:18] mautic.NOTICE: TypeError: Argument 1 passed to “Symfony\Component\EventDispatcher\EventDispatcherInterface::dispatch()” must be an object, “NULL” given. (uncaught exception) at /var/www/mautic/vendor/symfony/event-dispatcher/EventDispatcher.php line 63 while running console command mautic:campaigns:trigger {“hostname”:“m”,“pid”:2251637}
[2024-02-28 22:37:18] mautic.WARNING: Command mautic:campaigns:trigger exited with status code 1 {“hostname”:“m”,“pid”:2251637}

Steps I have tried to fix the problem:

I tried to identify the step that is causing the error.
Cache clear did not help.
Attributing correct permissions did not help.

Could it be that I am using php 7.4.33 and should update to 8 ?