Can not find mautic v4.0

Your software: Mautic v 3.3.5
My PHP version is : 7.3.31-1
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version: 10.3.31-MariaDB-0+deb10u1 Debian 10

Updating/Installing Errors: Great! You are running the current version of Mautic.
I am (delete as applicable): Installing / Updating
Upgrading/installing via (delete as applicable) : Web / Command Line: Upgrading via cmd sudo -u www-data php /var/www/html/mautic/bin/console mautic:update:find

These errors are showing in the installer :

These errors are showing in the Mautic log :slight_smile:
mautic.NOTICE: Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘ALTER TABLE mautic_forms ADD progressive_profiling_limit INT(11) DEFAULT NULL;’: SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs (uncaught exception) at /var/www/html/mautic/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 106 while running console command doctrine:migrations:migrate
mautic.WARNING: Command doctrine:migrations:migrate exited with status code 1
mautic.WARNING: Command mautic:update:apply exited with status code 1

Note: These are the errors before upgrading to 3.3.5. I solved them by changing column type from varchar to blob in database but for some reason are still there after upgrade from 3.2.4 to 3.3.5 , even after cleaning the cache.

Your problem
My problem is : After successfully upgrading to v3.3.5 , running the command sudo -u www-data php /var/www/html/mautic/bin/console mautic:update:find gives Great! You are running the current version of Mautic. and not the next version of mautic - v4.0/v4.2

Steps I have tried to fix the problem : First tired Mautic update failed - how to recover | Mautic , and it didn’t work. Then upgraded php to 7.4.28 and manually installed v4.2.0 downloading the zip file wget and replacing the files but got the error:

Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.4.0”.

Would appreciate any suggestions!


Yeah, about the composer error:

make sure you run composer with php7.4 not 7.3, try running:

/usr/bin/php7.4 /usr/local/bin/composer // If that does not work check where on your system composer and php7.4 are installed.

About the false result of find command. During pre-checks I think find checks the local.php for specific values and tries to be smart about the upgrade - which is not always the best. The easiest way to solve this is to download latest version from GH manually (like you did above).

For those that struggle with this, I found the issue to be that the php-cli was still in the 7.3 version instead of the required 7.4, after upgrading to 7.4 the new version was found.