Mautic Community Forums

Error when trying to go to step 2 on the installation proccess

Your software
My Mautic version is: 3.1.1
My PHP version is: 7.3

Your problem
My problem is:
When installing Mautic at step 1, after filling in all fields about Database host, name, port, username, etc I clic on next and I see a message

"An error ocurred while attenting to add default data: An excepcion ocurred while executing “CREATE INDEX mkt_instagram_seanch ON mkt_leads (instalgram): SQLSTATE[42000];Systax error access vialation: 1118 Row size too large. THe maximum row size for the used table type, nor counting BLOBs, is 8126. This includes storage overhead, check the manual, to change some columns to TEXT or BLOBSs”.

These errors are showing in the log: Not checked

Steps I have tried to fix the problem: No one

The app is being installing in a Cloudways server for testing.

Any help will be appreciated.

Thanks.

What version of MySql or MariaDB are you running?

@rcheesley can that be added back to the support post template? IIRC it was included when M3 was released.

Hello EJL, I am not sure about the version of MYSQL. I deleted the server because it was for a test. I will try again soon and I will check the version of the database engine.

Thanks anyway.

Regards.

PD) Maybe we can close the topic. I case I will have the same issue I will open a new one.

Hello mates, I have setup the server again and I arrive to the same issue in the step 2.

The version of mysql is: Versión Database Manager: 5.5.5-10.1.46-MariaDB-1~stretch a través de la extensión de PHP MySQLi

Any ideas how to proceed?

Regards.

Good evening.

The minimum requirements for MariaDB is version 10.2
MySQL version is 5.7

Version 10.1 is not compatible with Mautic 3.X

Hello EJL,

Thanks for your quick answer. I will see if possible to update the version of the mysql engine and try it again. I was supposing with Cloudways all software would be the most recently. I was wrong.

Thanks again.

1 Like

Hello mates, my question is solved.

I have just to setup MariaDB version 10.2 in the Cloudways configuration and then no issues with the step 2 of the Mautic installation.

You are allowed to setup until MariaDB 10.4. I am not sure which is better so, I setup 10.2

Thanks for your support and have a good day.

1 Like