Mautic Community Forums

Cannot login after a broken update

do not work. I copied local.php that is working to the installation that do not work and chage the variables to the installation that do not work. Check DOS carriage and it’s correct. The login page appears, but when insert user and password it just reload the page and the same error is logged:

[2019-10-30 21:54:02] mautic.NOTICE: Symfony\Component\Console\Exception\RuntimeException: Too many arguments, expected arguments “command”. (uncaught exception) at /home/mysiteuser/public_html/mautic/vendor/symfony/console/Input/ArgvInput.php line 182 while running console command mautic:broadcasts:send

That mautic:broadcasts:send error is from incorrect variables added to it. Have you tried to login/access your install via incognito mode?

I’ve tried it cleaning all cache, history, different browsers, etc. In all cases same error, with the old local.php

With the new local.php same errro, but in incognito it works !!!

Everytime I changed local.php I’ve cleaned cache.

No I don’t know yet what is the problem. LoL

Something in your browser profile is corrupted. If it’s working in incognito, but not in regular mode, it’s not Mautic.

You need to clear out the cookies and stored data for your install. Follow the steps below. If that doesn’t work, you might have to go all out and delete the entire browser cache. Just unselect the items like Download History and Password data if you want to retain them.

About this last step ok. After using the new local.php file it worked. What I do not know, is the real problem before using this new local.php file. What is wrong in the old php file.

1 Like

As I said before, that old local.php you posted to pastebin was in DOS format. That could be the culprit. I don’t know for certain. Post the new local.php to pastebin and I can compare them.

1 Like

https://pastebin.com/pf204Lu7