An error occurred while checking for updates. Please try again later. (SSH request fails?)

Your software
My Mautic version is: 3.3.3
My PHP version is: 7.425
My Database type and version is:

Your problem
My problem is: I have asked my host to update mautic following @joeyk 's amazing guide https://joeykeller.com/update-mautic-3-to-mautic-4-via-ssh/. This mautic is a on a shared host (yes I know that is not ideal) so I have my amazing host do updates for me.

But this time
"However, it appears that when I try to request a newer version via SSH with the following command:

php bin/console mautic:update:find

The error below occurs:

An error occurred while checking for updates. Please try again later.

Since the error message itself does not provide enough information for troubleshooting, I cannot update you with details as to why the update failed.

These errors are showing in the log: None

Steps I have tried to fix the problem: Clearing the cache

seems very strange. What version are you updating from ? are you trying to update to 4.0.2 ?

maybe try run php7.4 bin/console mautic:update:find or maybe even add a sudo before ?

Just shooting in the dark

Thans Mike,

Seems my host has been able to update from 3.3.3 to 3.3.4 but now when they looking for next update, and I quote,

"However, when I try to find newer updates with the following command:

php bin/console mautic:update:find

The following message occurs:

Great! You are running the current version of Mautic."

So I am at the same spot but one version more recent. What could be the reason mautic is not finding version 4 with

php bin/console mautic:update:find

?

I have experienced a similar issue but just waited a bit and reran and I think it found it.
If you look on your mautic instance do you see a notification for the next version yet ?

Just checked and the notification is there.

Will ask my host to try again. Hopefully it is just a time delay thing as you have suggested.

The front end of Mautic shows a notification that there is a new version 4 update available. But running the SSH command php bin/console mautic:update:find

says we are running the latest version. We are on 3.3.4

I have waited 24hrs between update attempts as I suspected there maybe a time delay issue.

Is there another way to get the update package and still update via SSH?

Have you tried to clear your cache and then check for updates?

Quite often this will catch me out when it doesn’t find the update - clearing the cache sometimes helps with that!

Thanks Ruth,

Yes, we have.

In fact clearing the cache did solve the very 1st issue I had and the reason for this post.

The issue has evolved since then to the where version 4 is not being found by the SSH command and we are being told we are on the latest version.