Mautic Instance not getting upgrade with latest version 4.4.6

Your software
My PHP version is : 7.4.33
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version : 10.5.18

Updating/Installing Errors
*I am : Updating current mautic (3.2.0) with latest (4.4.6)
*Upgrading via : Command Line

Your problem
My problem is :
I run “php bin/console mautic:update:find” command. So, It’s showing latest version 4.4.6 but when I am going to run “php bin/console mautic:update:apply --finish” command then it showing - Step 3 [============================] Success! You are now running version 3.2.0 of Mautic. (Rather then 4.4.6)

The --finish is only to be used as the final step of the installation - are you running the first step? It’s not clear from your post.

Yes, I Run below commands.

  1. php bin/console mautic:update:find
  2. php bin/console mautic:update:apply
  3. php bin/console mautic:update:apply --finish

Please let me know if I missing something or something else…

Sometimes this is because you have not got the right version of PHP. Please check the version that is running at the command line, this might be different to what Mautic is using.


I think the issue is different. Because of my cli and mautic both php version are same. I attached screenshot of it. Can you please see it.