Can't activate index_dev.php

Your software
My Mautic version is: 3.1.0
My PHP version is: 7.2.31

Your problem
My problem is: I have an issue with email tracking, and I want to debug it. I’ve tried to enable index_dev.php, but I receive internal error

These errors are showing in the log:
no errors in log

Steps I have tried to fix the problem:
I have installed mautic from github
I have enabled IPs in dev_hosts in local.php

Quick check - did you clone from Github or download from the release package? You weren’t specific in your post.

Release builds do not contain the dev/testing stuff. Double check that you have the file in your instance?

Hi Ruth,
thanks for the response.
As currently in the github version there is an issue that prevents the builder from working, we had to install from build and then we added all _dev files.
I am stuck, because build version doesn’t track emails, no errors in log, and to enable dev version I have to use github sources that can’t build an email, and I can’t reproduce the issue

That issue on Staging has been resolved now :slight_smile: This is the PR which fixed the issue.

I’m gonna try a fresh staging install.
I’ll let you know.

We have solved.
we missed a configuration in nginx.
Now it works, and the builder works too!
P.S. To all people using Nginx: dev environment requires specific configuration. If someone needs it, ask

1 Like

Maybe share that in case folk come across this in the future and you’re not here to reply? May be useful!

the command needed to activate index_dev.php is

location / {
try_files $uri /index_dev.php$is_args$args;

it’s possible to insert both index.php and index_dev.php in try_files, but we chose to activate and deactivate index_dev.php manually for security matters.