Mautic 5 VPS See only content of index.php

Good evening Mautic-Community (at least, where I am is evening :wink: )

My Mautic version is: 5.0.1
My PHP version is: 8.1
My Database type and version is: MySQL

My problem is:
After setting up a VPS (apache2) with Mautic, I want to go to the login page and setup Mautic itself. Unfortunately, I simply see the content of the index.php file in my browser.

These errors are showing in the log: No log available, probably because nothing happend yet

Steps I have tried to fix the problem:
I checked the permissions of www-data in /var/www and set it correctly
Checked all firewalls
Checked the .conf in sites-available
I tried to add manually /index.php/installer but without success

I think, it is not much wrong, but unfortunately I cannot find the last bit, which is missing. Thank you for your comments!

Kind regards,

Hi there!

It sounds like there’s something wrong with how you’ve set up your server.

First hit on Google was this:

Maybe the selected answer might give you some pointers?

Hey thank you the pointer was succesful!
I then found this method:

So now I have been able to setup mautic, but unfortunately after the setup comes a 404 for my mautic instance. This is what I am currently investigating