Can't install mautic via composer

Your software
My PHP version is : 7.4

Updating/Installing Errors
I am: Updating
Upgrading/installing via: Command Line

These errors are showing in the installer : /home/ubuntu/.cache/composer/vcs does not exist and could not be created.

These errors are showing in the Mautic log :

Your problem
My problem is : I’m trying to switch my installation to composer. Everything is working just fine on the existing install that is not on cmposer. When I’m trying to run the composer create-project command as the docs show, I get a composer error that says mkdir(): Permission denied when I’m running as the ubuntu user. I assume that I should run everything as www-data since that is the user that will be utilizing the installed files. So when I run the same command with sudo -su www-data prepended to it, I get an error message from composer that says /home/ubuntu/.cache/composer/vcs does not exist and could not be created.

Which user should be running the composer create-project command?

When I run as root, the install completes but that seems like poor form… If it’s run as www-data, how do I get past the error with the composer cache directory not existing?

Since I can’t get this working I’m sticking to my regular old install. Luckily that was easy to bring back online. Looks like composer-based installs aren’t working at all right now because of this bug: bin/console script must be update to work with composer install · Issue #10957 · mautic/mautic · GitHub.

Hello @gabe,

Can you specify which documentations you are following (URL) for your installation via Composer please?

Pierre

and

Hello @gabe,

I think this is an old version of the documentation and may not be up to date.
Can you try with this page ? How to install Mautic — Mautic Documentation 0.1 documentation

@rcheesley Wouldn’t it be appropriate to cut out the old documentation and redirect to the new one?

Pierre

Not at all. It’s still a work in progress and largely incomplete.