Cleared cache, Mautic down

I deleted cache in Mautic 2.15
Mautic went down, error 500

Why? Any reason for this?
I’m not able to let it work anymore

Hi, make sure files are right ownership:
if the webserver runs as www-data, then:

chown -R www-data:www-data /var/www/html/mautic/

Also: check rights:
chmod -R 755 /var/www/html/mautic/

You can also rebuild cache and see if you get errors. If you are root, you can run it as the web user:
sudo -u www-data php /var/www/html/mautic/app/console cache:clear

Good luck

I have Mautic in a shared webhost, permissions of mautic installation are rwx --x — for the main folder and rwx r-x r-x for the subfolders

Find the directory mautic is installed in, and find the owner of that directory, for example, if mautic is installed under: /home/username/public_html/mautic I’ll find the owner using:

ls -l /home/username/public_html/mautic

If you check that, then it might have been replaced with the root user cos of the way you cleared the cache, so, just change it to www-data as that is the default web server user, at least on Ubuntu, change it using:

chown -R www-data:www-data /home/username/public_html/mautic

Now, whenever you want to clear your cache, use the app/console and run it as www-data, e.g:

sudo -u www-data php /home/username/public_html/mautic/app/console cache:clear

Note: I am assuming, mautic is installed under /home/username/public_html/mautic, so you might wanna adjust that to wherever mautic is installed.

Hi guys,
it is a shared web host, I can’t use the shell.

Mautic is installed in a subdomain…it always worked, I don’t understand why deleting the cache folder could cause this sort of issues…

Today I cleared the cache again and it worked.
I didn’t need to change any file permission

No sense in this…