Deleted contents of var/cache folder, now I'm unable to load site

Your software
My Mautic version is:3.2.4
My PHP version is:7.4.14
My Database type and version is: MySQL 5.7.33

Your problem
My problem is: I deleted the contents of var/cache per the troubleshooting documentation (Troubleshooting | Mautic Community Documentation). Now I’m unable to even access and load the site.

These errors are showing in the log: I don’t see anything in the logs for today’s date

Steps I have tried to fix the problem: Not sure what to try

Clear browser cache or open in incognito tab. If that doesn’t work, set permissions for your cache folder and var/logs folder


I have cleared browser cache and cookies several times. I tried opening it in ingotnito window and that didn’t help. Also, the permissions are set to 755.

Try 775 on permissions. Are you on a VPS or dedicated server?

I set the var/cache folder to 775 and set the var/logs to 775. I am on a VPS.

BTW, I also happen to look at my var/.htaccess and it says “deny for all” ? Should the .htaccess file say that?

If someone tries to access the folder directly via it will give a 403 error. I do not think its related.

Have you tried restarting apache? On Centos7 via command line: “service httpd restart” will do the trick. Your system may vary a little based on OS

I rebooted the server on WHM and it didn’t have any effect. Still can’t access my site

apache logs dont show anything? No errors in php logs? turn on debug option, and check mautic/var/logs/

I decided to save my database and uninstall the Mautic script and then reinstall a fresh clean version to that same subdomain. I use Softaculous on cPanel to do the install.

Now, with the fresh clean install and new database I can’t access the site at all. I get a message from my browser that its getting too many redirects. I don’t understand why a fresh new installation won’t let me access it. I’ve tried clearing the cache and cookies and an incognito window as well.

I have open a support ticket with my host and see what I can figure out from that end first. A clean install should work.

Did you save a copy of your local.php before you migrated? Is your sql driver set to pdo? Top few lines of local.php file

No, I did not. As an update for this morning. I just was able to access the new installation of Mautic from an Incognito window. My host indicated that I was getting too many redirects from Cloudfare. I’ve disabled Cloudfare for that subdomain.

I didn’t have a lot of data (maybe a weeks worth) in my previous Mautic installation as I was just setting things up.

I’m still unclear of why when I cleared the contents of var/cache that it broke Mautic. Maybe I went about it incorrectly. I was following the instructions in the Troubleshooting section of Mautic. This all originated because I was attempting to connect my Mautic instance to Zapier. I was advised to clear my cache folder contents, so I did.

I’ll attempt to try to connect it with this fresh install but I need to re-configue some of the settings I had already had in place.

in the future you can save the local.php file and use it to restore your settings by copying into the app/config folder of any new installs.
If I recall correctly the Zapier plugin in nonfunctional due to some changes on Zapier’s end but it may be sorted out by now.
Unfortunately the documentation for Mautic is far behind its development. Its being addressed, but it isn’t current as I understand it.
If you have ssh access you can run the cache:clear command as opposed to deleting the whole folder.

That’s good to know about the local.php file. Where exactly is that file located?

Makes sense with regards to Zapier. Do you know if Integrately works? I know they have a mautic connector. (and Integrately costs far less to use than Zapier)

I do have SSH access, although I know enough to be dangerous, I try to stay away from shell commands unless absolutely necessary. After going through this though I probably will use the shell command next time.

I’m reconfiguring the new mautic install now. I’m so much faster at it the second time around! LOL

I really appreciate all your help. Thank you🙏

I haven’t used integratedly so I cant offer any input.

Its no trouble. I hope it remains problem free.

In light of the Zapier issue, I’ll test out Integrately for a successful connection. I’ll let you know.