Deleted Cache related issue. mautic.CRITICAL: Uncaught PHP Exception

Your software
My Mautic version is: v3.1.2
My PHP version is: 7.3.24
My Database type and version is: MySQL

Your problem
My problem is: My mautic site crashed after i cleared the cache. I am using filezilla to navigate. I am a marketer, so i am not very familiar with servers, databases and coding. i do know how to read codes though. if someone has encountered that error please let me know how you fixed it.

These errors are showing in the log: [2022-05-02 22:29:31] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalErrorException: “Compile Error: require(): Failed opening required ‘/var/www/html/marketing/var/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/usr/share/php’)” at /var/www/html/marketing/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php line 206 {“exception”:"[object] (Symfony\Component\Debug\Exception\FatalErrorException(code: 0): Compile Error: require(): Failed opening required ‘/var/www/html/marketing/var/cache/prod/doctrine/orm/Proxies/__CG__MauticPluginBundleEntityPlugin.php’ (include_path=’.:/usr/share/php’) at /var/www/html/marketing/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php:206)"}

Steps I have tried to fix the problem:
Already followed the steps here Troubleshooting | Mautic
but nothing seems to work out.

You are mentioning SSL. Do you have issues with your SSL certificate?
How did you clear the cache? Deleted the respective folder’s content?
Here is a short guide on cache:

This is not a proble m related to digital dcertificates.

Probably you deleted the entire folder and Mautic is not able to recreate it.

With your FTP program, check if the folder var/cache exists.

Try to access the login page of Mautic and check if there any errors. Then check again if the folder exists and if in it there is the prod subfolder.

If it doesn’t exists, then check the files and folders permissions

Fix them if required.

Then try again to access the login page.

If the errors continues to happen, then you need an SSH access to launch some commands: can you access the shell?

Please: change the title of this thread as there is no relation with SSL.


Hello, thanks for the reply,
the prod folder exists as well as the rest of it. the issue still persists (500 internal server error).
Is this still related to file permission?
i can access shell


Solved the problem. it was more complicated than i thought because i had several issues at the same time. long story short i cleared my cache again.