Command Line Import

Hey @Yosu_Cadilla,

Once again I am battling with this issue. Where should I put the file ?
I thought it was enough to put it in /mautic/app/cache/imports
Then run mautic:import but nothing happens.

My file looks like this

and is saved as a csv.

Not seeing any error logs.

Any clues ?

Hi, message is for anyone that can help.

Problem remains the same as before, trying to run some auto imports but after following all the documentation I still cannot get it to work. (I do get it to work with the plugin, but this plugin is for specific use on importing my platform data)

I have read all over the net with the latest article about it here:

In this thread people claim that it works, can someone please walk me through step by step.

I have made a file for example:

I went and used iconv to convert the file from ASCII text to UTF-8.
I have placed it in app/cache/imports/test.csv
then ran the import cronjob, and nothing :frowning:

So any help would be so much appreciated

@mikew, actually in here:

People says it does not work and presents alternative approaches.

Does the import works or not? Does anyone knows about it?

I never got this working, had to use the custom-import-bundle plugin

I am trying manual installation:

But I can’t find the folder /s/ in Mautic directory. Does any one knows if it is related to the mautic version tha I’m running?

@mikew Did you find that folder when you did your installation?

After you have cleared the cache, simply go back to Mautic -> Settings -> Plugins.

You will then see the plugin:
You will only see the name custom. Click on it and you will be able to configure.

1 Like

I have already cleared the cache, but the plugin did not appear there.

Do you have any idea?

Did you do update/install on the plugins page ?

1 Like

First I tried to manually install.

After that I tried to click in:


On the plugins page. It means, install/update Plugins. But it says that 0 plugins were installed or updated.

What is your Mautic Version?

I am starting to think this problem is related to the Mautic version, since I’m not able to find the same folders that you see, inside the mautic directory.

I tried the automatic installation too:

  • composer require mtcextendee/mautic-custom-import-bundle
  • php app/console mautic:plugins:reload
  • Go to /s/plugins and setup CustomImport integration

The second steps says:
0 plugins were installed and 0 was updated.

Please help.