Constant Refreshing/Loading with No Action. Sometimes login doesn't work

Your software
My Mautic version is: 3.1.1
My PHP version is: 7.3
My Database type and version is: MariaDB version 10.2.34
Your problem
My problem is:
Login page doesn’t work 99% of the time. When it does work (once on the first softaculous install, then I reset password and am locked out), I try to navigate the dashboard and it does nothing except show the quick loading bar.
Here’s a video:

These errors are showing in the log:
No log being created

Steps I have tried to fix the problem:
Reinstalling mautic a bunch of times with softaculous, confirming server requirements, contacting inmotionhosting support, replacing default htaccess file (recommended by IMH)

Softaculous installs seem to be prone to buggy behavior. If you can, install from a copy directly from

I assume your server has a panel if it has softaculous. Is it cpanel? Plesk? Something else?

There has to be a log generated somewhere. Apache error logs, Php error logs, mautic error logs. Mariadb logs.

Right click on browser and open the dev tools and look for errors when you click, refresh, etc

Thanks so much for your help.

I tried the the install from Setup process works. When I log out, I can’t log back in and the same refreshing issue happens. It doesn’t actually log me out - I can just visit the dashboard again too. It seems to keep me logged in via incognito even if I have never logged in via incognito…

Zero errors show on console on login screen.

cpanel is in use

IMH says there are no errors

Sent you the only logs that had any record in a DM…

What does the console say when you actually login, click settings ect. Are you running a VPN or VPN plugin? Reviewed robot.txt and .htacess ?

Just a quick idea: do you have wordfence or other protective wordpress plugin installed? That can cause similar issue.

@joeyk - none at all in this cpanel

@EJL - yes, reviewed robot.txt and .htaccess - both default and installed by either softaculous or came as default from No VPN. Literally no console errors in browsing around the entire app. Truly weird - I can just visit the login page, login once, browse around, click logout, and then directly visit the dashboard again without logging in…The login page no longer works (I guess because I’m already logged in somehow, as it’s letting me browse around even after logging out).

I just tried updating to 3.1.2 and the log shows this error - maybe this will help (update failed):
[2020-10-28 19:28:26] mautic.ERROR: An error occurred while attempting to fetch the package: cURL error 3: (see

After a while of browsing around, the settings no longer load at all. It gets stuck on Dashboard page. Even going directly to incognito to this URL just let’s me login - looks like it’s public to just browse my dashboard…

check and set file permissions on your log and cache folders. @gauchoplugins

They were checked early on and confirmed based on this documentation.

Any other ideas?

Really appreciate your help!

cookies being blocked? caching issue? miniscule php settings. pdo_msql set on line 3 of local.php? Line 121 of local.php debug set to true? Anything crazy in local.php as far as weird log paths or cookie settings starting at line 60?

Click the top right gear, click system info, folder and file ? Whats log say?

With a failed upgrade midstream this isnt going to get easier to troubleshoot. Are you able to download 3.1.2 and do a fresh install? Not softaculous.

Are you running nginx in front of apache? Pagespeed module? Lightspeed caching? What is listening on port 80 or 8080? What are your rewrite rules pertaining to ssl?