Custom email does not work in 4.3.1

Your software
My Mautic version is: 4.3.1
My PHP version is: 7.4.29
My Database type and version is: pdo_mysql / 5.7.38

Your problem
I’m trying to compose an email using code mode, but when i save it keeps reverting back to the “Blank” template. This was working fine in 4.2.2. I have tried using grapesjs and the legacy builder (cache was cleared each time, browse cache was flushed each time - also tried each time incognito).

Video here - saving

These errors are showing in the log: None

Steps I have tried to fix the problem: turned off grapesjs and cleared the server / browser cache


I had sort of a similar issue but not exactly the same as you.

What I did was to select email theme then open builder and close builder then save it.

Try that see if that help you save the theme you selected.

I’m curious so let me know the result.

Hi Bill,

I’ll give that a try right now…

In 4.3.1, using grapesjs - there is no builder for code mode. You need to go to the advanced tab and edit the code there. So, it didn’t work.

I went look on mine and you are right. Builder is greyed out and it did the exact same thing on mine when I saved it which jumped to another theme when saving.

It’s seems to be a bug to me.

1 Like

Glad im not the only one - i can’t even get the code block to work in the grapsejs

Yes, I’m having this same issue. Is there a work around? I can’t edit or save any emails from the templates

This might be connected to this?

Fixed in Code mode fix by escopecz · Pull Request #11221 · mautic/mautic · GitHub. Ready for testing.

This fixed it for me! Thank you once again!

I was able to fix my problem by turning off ModSecurity (in cpanel) on the domain that I have mautic running on. For some reason, I the plugin blocks saves and changes to the template. I use Namecheap hosting,