Mautic Community Forums

Date Based Campaign

Your software
My Mautic version is: 3.0.2
My PHP version is: 7.2

Your problem
My problem is:

When trying to setup a Birthday Campaign it does not seem to trigger correctly

These errors are showing in the log:
None in System logs, none in /var/log/nginx/mautic.error log either

Steps I have tried to fix the problem:

Installed a clean version of Mautic-3.0.2.
Added a custom field of type date - Date of Birth.

Added a user and added users test birthday
image

Created test campaign with a condition on contact field=Date of Birth and set date = anniversary
image

Added an action to send an email on the positive path
image

Ran cronjob manually and not getting any email and this is what is shown in campaign conditions report:
image

Today is the 28th July.

No error in logs neither through the UI or server logs.

Same problem with custom field and filter = Today

Can cofirm too. It does work on 2.16.2
I’ll open a bug on it in Github

How is the condition mean to be written for contact field date to equal today.

I remember doing it in the past and did not use operator date, but used operator equal and tried variation of “today” and “Today”

and in date, anyone know what POD -P1D +P1D

addition:
just checked on Mautic 2.16.3 and created a segment with date equal “today” and this worked perfect.

Further Addition:
Check campaign on Mautic 2.16.3 and worked fine. The main difference in Mautic 2.16.x is that on date operator you have the dropdown of “is Today”

That looks like another issue. i Guess that P0D means “Plus 0 day” (today) +P1D plus one day maybe means tommrow

Thanks @OmerGafny, so tried these filters too but did not work either

I tried this option +P0D on the campaing, again with custom field - date= 2020-07-27.This campaign doesn’t work.

#Update
Contact with custom field/date = 2020-07-28
Segment with filter = custom field = today
On 28.07, contacts in this segment = 0
Today 29.07, contacts in this segment = 1(Custom field/date = 2020-07-28)
Result - Campaign with this segment = Works

@mmkolev was this done in Mautic 3.0.1 ?

After update to Mautic 3.0.2

@rcheesley are you aware of an issue for this in GitHub, if not point me to the right place and I will add it.

Thanks,

Mike


Here is the issue