Mautic Community Forums

Disable auto generation of 'p' tags in Landing page

Here are some codes i’ve in theme - page.html.php

Quote:
<?php if ($view->hasContent('ourmission-title')): ?>

<?php $view->output('ourmission-title'); ?>


<?php endif; ?>

Whenever I write some text inside the 'div' from Landing Page builder, It creates 'p' tag automatically, which is messing with the design. In browser i get the above code this way -
Quote:


Be Part of Our Mission



If i use 'div' instead of 'p' tag for the slot ourmission-title. I still get an extra 'p' tag. Here is the html i get in browser -
Quote:

Be Part of Our Mission



So, my question is- How can i disable/stop creation of these 'p' tags?

Thanks in advance for your support.

Here are some codes i’ve in theme - page.html.php

[quote]<?php if ($view['slots']->hasContent('ourmission-title')): ?>

<?php $view['slots']->output('ourmission-title'); ?>


<?php endif; ?>[/quote]

Whenever I write some text inside the ‘div’ from Landing Page builder, It creates ‘p’ tag automatically, which is messing with the design. In browser i get the above code this way -

[quote]

Be Part of Our Mission

[/quote]

If i use ‘div’ instead of ‘p’ tag for the slot ourmission-title. I still get an extra ‘p’ tag. Here is the html i get in browser -

[quote]

Be Part of Our Mission

[/quote]

So, my question is- How can i disable/stop creation of these ‘p’ tags?

Thanks in advance for your support.

That’s a “feature” of CK editor which Mautic uses. I’m afraid there is no way to switch the editor off right now. There are few editor related issues right now:

https://github.com/mautic/mautic/issues?utf8=✓&q=is%3Aissue+is%3Aopen+editor

Feel free to create a new one if none is related to yours.