Mautic Community Forums

Entering a landing page

When creating a landing page all goes well until i try to save & close or apply.



I’m presented with what appears to be a saved form but cannot click anywhere else. exiting that form does not save it.



Anyone else having this happen ? it only occurs when using self-hosted.

No themes being used

error log from the mautic directory below

[14-Jan-2016 00:47:00 UTC] PHP Fatal error: Call to undefined function MauticConfigBundleModelmb_strlen() in /home/ptkkbpjo/public_html/mautic/app/bundles/ConfigBundle/Model/SysinfoModel.php on line 138

Install Multi Byte PHP extension: http://php.net/manual/en/mbstring.installation.php

That didn’t help but thanks - landing form stays the same without saving.

can i provide you with credentials to see this ?

Hello,

We have enabled the PHP module “mbstring” for you.

You can see a list of available modules you can enable yourself in cPanel in the PHP Selector:

https://my.hostmantis.com/knowledgebase.php?action=displayarticle&catid=42&id=156

Be careful enabling/disabling modules as it can break scripts that do not require those modules.

Thank you,
HostMantis Support
support@hostmantis.com

Does the same error message still appears in the logs?

same error but this is old date - yeterday

[14-Jan-2016 00:47:00 UTC] PHP Fatal error: Call to undefined function MauticConfigBundleModelmb_strlen() in /home/ptkkbpjo/public_html/mautic/app/bundles/ConfigBundle/Model/SysinfoModel.php on line 138

I overlooked the path. It was fired in the System Info page. It’s not related to the Landing Pages. No JS error? Otherwise I’m getting out of ideas about what could cause it.

great - moving to plan B

I guess plan B was no good. Have been trying to figure out why my landing page settings won’t save. Can anyone chime in on this ?

At first tried changing some php settings from my host acct. but that did not go too well. Here’s a link to a video describing the issue: http://www.screencast.com/t/szgHOP7Wn

Thanks in advance

I’d really like to help you, but without an error message from the logs I have no idea what could cause it.

I know. I will find a solution.

Thanks -

Where are all the places I should look for error logs ?

Every server can have the error logs elsewhere, but in my Ubuntu, the default location is /var/log/apache2/error.log . Mautic stores logs to app/logs folder by default.

Found the issue -

Taking a look at server level logs, we see some 403 errors due to ModSecurity rule violations on your account from your IP address, which is most likely the issue which you are experiencing.

We have whitelisted your account for the rule and you should no longer have an issue with it.

Thank you,
HostMantis Support
support@hostmantis.com

Do you by chance use a custom (3rd party) theme?

Is there some error message in the server or Mautic logs (app/logs folder)?

If you press F12 and go to the Console tab, is there some error message?

When creating a landing page all goes well until i try to save & close or apply.

I’m presented with what appears to be a saved form but cannot click anywhere else. exiting that form does not save it.

Anyone else having this happen ? it only occurs when using self-hosted.