Mautic Community Forums

Error 500

Hi,



Had mautic installed and working properly, today I had to restart the server and when I tried to access the web I get “HTTP Error 500”.

I have tried to raise a copy a week ago and I get the same error, I can only access the machine through ssh.



Could anyone help me solve this problem ?, there is important content in Mautic.



Thank you



Hi,

Had mautic installed and working properly, today I had to restart the server and when I tried to access the web I get “HTTP Error 500”.
I have tried to raise a copy a week ago and I get the same error, I can only access the machine through ssh.

Could anyone help me solve this problem ?, there is important content in Mautic.

Thank you

Aplicaste los permisos a los directorios?

Yes, I cleaned the cache was the first test I did, how do I check that the cronjobs are running under the web server and not roor?

Si, limpie la cache y asigne los permisos al directorio app/cache/prod que es el que suele cambiarse los permisos y sigue en el mismo estado

What web server are your running? Version of PHP? Apply any updates? Is the disk drive full?

If Ubuntu 16 with a stock Apache setup, edit this file with vi or nano:

nano /etc/apache2/sites-enabled/000-default.conf

Below <VirtualHost *:80> add or change the existing LogLevel so it looks like:
LogLevel trace8

Save the file and then run this from the command line:

systemctl restart apache2

Then run this from the command line:

tail -f /var/log/apache2/error.log

Then reload your site with the web browser and you should get more information as to why you’re seeing the Server 500 error.

Also check check the Mautic log file for errors (adjust the date as needed):

nano /var/www/html/app/logs/mautic_prod-2017-04-11.php

[quote=22138:@redneckbob]What web server are your running? Version of PHP? Apply any updates? Is the disk drive full?

If Ubuntu 16 with a stock Apache setup, edit this file with vi or nano:

nano /etc/apache2/sites-enabled/000-default.conf

Below <VirtualHost *:80> add or change the existing LogLevel so it looks like:
LogLevel trace8

Save the file and then run this from the command line:

systemctl restart apache2

Then run this from the command line:

tail -f /var/log/apache2/error.log

Then reload your site with the web browser and you should get more information as to why you’re seeing the Server 500 error.

Also check check the Mautic log file for errors (adjust the date as needed):

nano /var/www/html/app/logs/mautic_prod-2017-04-11.php [/quote]

I used a bitnami instance and the log in Apache is:

[Wed Apr 12 08:12:46.571521 2017] [core:notice] [pid 2118:tid 140243146761984] AH00094: Command line: ‘/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf -D DISABLE_BANNER’
[Wed Apr 12 08:15:06.376798 2017] [proxy_fcgi:error] [pid 2123:tid 140242999568128] [client 83.56.203.41:62520] AH01071: Got error ‘PHP message: PHP Parse error: syntax error, unexpected ‘=>’ (T_DOUBLE_ARROW), expecting ‘)’ in /opt/bitnami/apps/mautic/htdocs/app/config/local.php on line 98n’

Log in Mautic is very old

What version of Mautic are you running?
Version of PHP?
Apply any updates in the last few days?
Change the configuration of Mautic in the last few days?

Post lines 90 through 100 for this file:

/opt/bitnami/apps/mautic/htdocs/app/config/local.php

I’m betting there is a messed up line in your configuration.

[quote=22140:@redneckbob]What version of Mautic are you running?
Version of PHP?
Apply any updates in the last few days?
Change the configuration of Mautic in the last few days?

Post lines 90 through 100 for this file:

/opt/bitnami/apps/mautic/htdocs/app/config/local.php

I’m betting there is a messed up line in your configuration.[/quote]

Mautic version: 2.2.1
PHP version: 5.6.22
No update in the last days
No, I haven´t change configuration Mautic, I only create Landing Page, Form, Campaings and email

I need the code, I cannot parse a screenshot that has encoded html, so what should be <!-- is now <-- which hurts my brain.

Did you add the twitter code? It looks busted, as if the copy-paste was in the wrong spot or only picked up part of the code.

Don’t know if you can remove the Twitter tracking and see if that fixes it, but a HTML comment opens up and then doesn’t close before another one opens up. I’m about to crash because it is 5am here, but if you want to email the local.php to redneckbob@rocketmail.com I can look at in a few hours.

It should look more like this:

Than this:

@jesus.montejo - You get this working?

Yes, that was the problem @redneckbob , I deleted all those comments and Mautic has already returned to work.

Thank you very much!.

I could not answer before because in Spain it was a party and we did not work.

Thanks again.