Mautic Community Forums

Error message after changing PHP mode

Hi Alan,



congratulations for release 1.0!!



I recently changed the php mode of my server from CGI to Apache-Module. Afterwards I changed the owner of all mautic files and directory to www-data which is the php user. Now I see the follwoing error message in the admin panel and other erros in my forms:



Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /www/htdocs/rsieber/mautic/vendor/joomla/http/src/Transport/Curl.php on line 155



Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /www/htdocs/rsieber/mautic/vendor/joomla/http/src/Transport/Curl.php on line 155



Also the update seems not to work anymore.



Robert

Hi Alan,

congratulations for release 1.0!!

I recently changed the php mode of my server from CGI to Apache-Module. Afterwards I changed the owner of all mautic files and directory to www-data which is the php user. Now I see the follwoing error message in the admin panel and other erros in my forms:

Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /www/htdocs/rsieber/mautic/vendor/joomla/http/src/Transport/Curl.php on line 155

Warning: curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /www/htdocs/rsieber/mautic/vendor/joomla/http/src/Transport/Curl.php on line 155

Also the update seems not to work anymore.

Robert

I believe this is an issue with the settings of PHP and safe mode. I thought it was resolved in PHP 5.4 and newer but perhaps I am mistaken. An alternative may be a problem with your hosting provider setting the open_basedir.

I believe these warnings will also keep the update from working properly via the AJAX call. I’ll verify this as well and update this thread. Please provide any relevant hosting provider information (e.g. version of PHP, status of open_basedir and safe_mode)

Thanks!
David

David,

thanks for getting back to me!

I use PHP Version 5.5 - as cgi it was 5.6

https://different-thinking.de/infophp.php

Robert

I’m running into the same thing with mautic 1.0.2 on PHP 5.5.23 (fast-cgi)

@menolo, can you report this at https://github.com/mautic/mautic/issues?

Thanks,
Alan

Hey Alan,

Done. See https://github.com/mautic/mautic/issues/299

Wim