Error while integrating Amazon SES with Mautic

Hi @joeyk I am so sorry I am bothering you so much. Just that I am a very new user of mautic and I don’t know much. I am trying to find my way through without any technical help.

Coming to your suggestion… I have verified my email address and I am using the right region.

Just FYI, I am using AWS SES on my site to send out confirmation emails using a WP Offload SES plugin, and I have used the same credentials over there. Could that be a reason for this issue of emails not getting sent?

Hey, no problem I’m glad to help (if I can)
You can use the same SES account across various software, that is not the issue.

Are emails not in spam by the chance?
Are you sending to an email, that is not blacklisted?

Hey @joeyk,

No, the emails aren’t getting sent.
I checked the SES email stats and they show no emails were sent.

At the moment, I am just trying setting up the email functionality with my own email addresses as contacts, so I don’t think the blacklisted address is the issue.

Hi @Shanbhag, I am not an expert but I remember how frustrating it was to setup the SES when I first started using SES. Check following:

Your account is out of sandbox
Your zone are in sync Mautic <> SES
Mautic: email-smtp.eu-west-1.amazonaws.com <> Amazon SES: us-west-1
Mautic: email-smtp.us-east-1.amazonaws.com <> Amazon SES: us-east-1
Mautic: email-smtp.us-west-2.amazonaws.com <> Amazon SES: us-west-2

Under the current zone you have following confirmed:
Domain and Email addresses that are used to sent email (be mindful of your admin email too)

All mandatory Cron are set.

Hey @tomr Thanks for your message.

I have done all that:

  • My account is out of sandbox

  • My zones are in sync with Mautic SES

  • Under the current zone I have verfied my email address and domain.

The only thing I am unsure about is the cron job. I don’t know how to set a cron job, so I checked a Youtube tutorial to guide me. Maybe I made a mistake somewhere.

Are you using the email queue feature?
If so, could you plz check if you have any files hanging in /mautic_path/mautic/app/spool/default/ folder?

Did you try to send test email from Configuration/Email where you entered the email data - if so did it arrive at all?

Here is a comprehensive intro to cronjobs and Mautic:

Keep me posted.

Hey @joeyk,

You’re right.

All my emails are in the spool/default folder.
These emails were a part of a trial campaign which I had set-up to test the emailing facility. They didn’t get sent. Neither did the the Configuration/ Email set-up test email arrive.

Okay, we are getting closer :slight_smile: 99% you have crons not configured properly. Could you plz paste your cron here?

/usr/local/cpanel/3rdparty/bin/php/home/nuvo/public_html/mautic/app/console mautic:email:process > /dev/null 2>&1

Okay, run it in command line without the dev/null ending. What happens?

Actually also try mautic:email:send

Also: please read my post above. It really explains the mautic crons.

I will read the post and make the changes and let you know how it goes. Thanks @joeyk

Hey @joeyk ,

I tried sending the email without the dev/null ending but they are still getting piled up in the spool/default folder. :confused:

Plz post here the response from your server when you try to send manually. (SSH). Also Don’t use ‘process’ but use ‘send’ command.

@joeyk Hi.

This is a bit too technical for me.
I will need to figure out how to do that. First, I need to figure out how to create a SSH user through cPanel. Let me try and figure it out. I will certainly get back to you here.

Sorry, I don’t know better way to debug this.

Hey @joeyk,

I am sorry. I am not able to get SSH access. I am hosted on a shared server and I was told I cannot get SSH access on a shared server. Is there any other way out?

Hey @joeyk,

I am back :slight_smile:

I have shifted my hosting to a cloud server, now.
But I, still find that my emails aren’t going.

I have changed my version to 3.1.2

My Amazon SES account is out of sandbox and I have configured SES correctly (because I received the test email).

But, my campaign emails aren’t getting delivered.

What should I do?
Thanks.

Hi,
did you set up the cronjobs?
if yes, what happens if you run them in the terminal?
Thx,
Joey

Hey @joeyk,

Thanks man for your prompt response.

I have set-up the cronjobs, I don’t know if I have set them up correctly, thought.
The reason I say that is, in this case, there are two variables – the cloud server and the newer version of Mautic (3.1.2)

I did test the output before setting them and there was no error.

Here’s the cronjob for sending email…

/bin/php /var/www/mmm.nuvop.com/bin/console mautic:emails:send > /dev/null 2>&1

Is this correct? (I’m asking because the test did not throw up any errors)

Thanks

Hi!
Remove the end and just run this: /bin/php /var/www/mmm.nuvop.com/bin/console mautic:emails:send

What does it say?