Mautic Community Forums

Errors after update (OneSignalSDKWorker), but not using OneSignal

Hello



I’v updated to 2.8 and i get these error in the console.



OneSignalSDKWorker.js:1 A bad HTTP response code (404) was received when fetching the script.

OneSignalSDKWorker.js Failed to load resource: net::ERR_INVALID_RESPONSE

ServiceWorkerHelper.ts:135 ServiceWorker registration TypeError: Failed to register a ServiceWorker: A bad HTTP response code (404) was received when fetching



I’m not using web notifications, the OneSignal plugin is disabled. So these errors shouldn’t be showing?

Is this a bug or should I edit something?


Hello

I’v updated to 2.8 and i get these error in the console.

OneSignalSDKWorker.js:1 A bad HTTP response code (404) was received when fetching the script.
OneSignalSDKWorker.js Failed to load resource: net::ERR_INVALID_RESPONSE
ServiceWorkerHelper.ts:135 ServiceWorker registration TypeError: Failed to register a ServiceWorker: A bad HTTP response code (404) was received when fetching

I’m not using web notifications, the OneSignal plugin is disabled. So these errors shouldn’t be showing?
Is this a bug or should I edit something?

Thanks for the quick response, I’ll do the patch.

The first options didn’t help, this gives another error.