Focus Item not showing on typo3 page

Your software
My Mautic version is: 3.3.2
My PHP version is: 7.4
My Database type and version is: 5.7

Your problem
My problem is: I created a focus item. I placed the code into the webpage via the typo3 Template.

These errors are showing in the log: No errors showing

Steps I have tried to fix the problem: I tried to insert via script in the section as well as in the section. But the item does not appear.

Hey @taxi

Can you past the exact script you are placing there ? I am not very familiar with typo.

I did find that focus items were not working with the exact code generated from Mautic, sometimes you might need to add /index.php and make sure it is a full URL including https://

I have written a small blog post on a similar issue I had with Wordpress, maybe it can help. check it out here.

One typical suspect would be that you’re mixing http and https (I think that’s what @mikew was hinting as well)
If that’s not the case, I’d suggest
a) look at the page source and verify that the script is actually present
b) Open your browser’s inspector and reload the page, watch for errors in the console


1 Like

I found the problem. I’m afraid to tell, but the focus item just was not set to “published” in Mautic.

Sorry for disturbing you all.

Many thanks for helping me with this issue.

1 Like