Form action url should start with https, but start with http

Your software
My Mautic version is: 5.0.4
My PHP version is: 8.1
My Database type and version is: 10.11.6

Your problem
My problem is:
Form action url should start with https, but start with http generated by mautic, my mautic site URL already set to https://, how to change it?
There is not this problem In Mautic 4.4.12, all works fine.

These errors are showing in the log:

Steps I have tried to fix the problem:

Hi, you shoudl regenerate assets:

bin/console mautic:assets:generate

Then open your form + save again.

Hi @joeyk , Thanks for your response. I followed your instructions, but the problem is still there.

Did you open and save your form again?

Yes, I did. And I created a new form, there is no change.

Could you plz check if your Mautic url starts with https in the config?

Gear icon > Configuration > General Settings > Site URL ?

If no, plz change to https, then

bin/console c:c
bin/console m:a:g

!! Open form + save !!

check again?

After I ran the 2 commands, I can’t log in mautic instance, how do I restart the mautic instance to login?

Did you run them as root or the web user?
Here is what happened:

I reinstalled mautic 5, after ran cache:clear and cache:warmup commands, the mautic down again.

can you confirm the right permissions based on my article above?

Yes, I followed the article actually.

Can you show a screenshot from the permissions?

ls -la

and www-data is your web user?

yes, www-data is web user.

Can you show example what is in your var/log folder to understand why mautic doens’t work? Is the problem, that mautic has no writing access to the cache folder?

Which log should I open?

Sorry, above is wrong

the below is correct