Form input requirement is kicking user back to our homepage instead of alerting them that input is needed

Your software
My Mautic version is: 4.2.2
My PHP version is: 7.4+
My Database type and version is: MySQL 5+

Your problem
My problem is: "Form requirement error are kicking user back to home page with URL parameter at the end of our home url.

?mauticError=Errors%3A<br%20%2F><ol><li>This%20cannot%20be%20left%20blank.<%2Fli><li>This%20cannot%20be%20left%20blank.<%2Fli><%2Fol>#btg_subscr

These errors are showing in the log: There nothing in log

Steps I have tried to fix the problem: I am not sure what step to take to fix this issue. This is why I am here posting about this issue.

I don’t think anyone is going to actually read the URL to see why they were kick back to homepage when they did not fill in all the required input boxes and also it is annoying of having to go back and fill in all the input boxes again because the information is not saved.

Here a page with just only a form on it … Click without inputting any email address

https://www.agwm.org/btg/test-three/

What is exactly it suppose to do? pop up an error box ?

This is a brand new Mautic install on a different server. Still same thing … I starting to think it something within Mautic

Here a form to try out Leave email box empty and just click submit

The error message will appear inside URL parameter but it just direct you back to main domain URL …

http://test.deafcoder.com/

I did some more testing and found this in browser console log … look like a JS error …

VM29:1 GET https://deafcoder.com/media/js/mautic-form.js?v32249c82 net::ERR_ABORTED 404 (Not Found)

The file “mautic-form.js” does not exist on both of the servers.

Does it get created during composer install or when something is set up within mautic?

I grabbed the :mautic-form.js: file from git and install it … That what fixes it …

Now the question is.

Why didn’t composer install this file on a fresh new install for me on two different servers?