General import/upgrade question

Your software
My Mautic version is: 4.4.12
My PHP version is: 8.0.30
My Database type and version is: 10.5.23-MariaDB-0+deb11u1

Your problem
My problem is: I want to upgrade to a supported PHP version (8.2) as well as Mautic version. I have the following question:

  • Does Mautic 5.1 support the import of leads, forms and campaigns from Mautic v4.4.12?

Our client has 147 forms in their current Mautic instance and I need a way to import those to the new Mautic 5 instance.