Mautic Community Forums

Has anyone success in getting Citrix GoToWebinar connection running with Mautic 2.15.2?

Your software
My Mautic version is: 2.15.2
My PHP version is: 7.x

Your problem
My problem is: Mautic is not pulling the webinars from Citrix. Initially we started to fix the authentification, but still no available webinars show up in campaign fields. Webinar fields are empty. The error log seems to be a bit missleading?

These errors are showing in the log:
[2019-09-25 05:40:01] mautic.ERROR: { “err”:429, “category”:“Rate limit quota”, “message”:“The API call rate has been exceeded for the day.” }

Steps I have tried to fix the problem:

Hello @dirk_s and welcome back to the forums!

The error you’re seeing seems to suggest that you have hit an API limit, could that be why you’re not getting the webinars through?

I found this (slightly old) thread which refers to the rates imposed in development mode: https://community.logmein.com/t5/GoToWebinar-Discussions/Issues-with-API-calls-getting-message-quot-The-API-call-rate-has/td-p/177312 - not sure if that might be a factor to be considered?

If you’ve hit the rate limit, you wouldn’t get any pulled through.

1 Like

Good one! Looks like the app is still in developer mode. The API Limit is hit already in the first hour of the day…

1 Like

Aha, that would do it!! Hopefully it will be an easy fix!