Help!Contacts that pass through a form are not merged

Your software
My PHP version is : 8.0.30
My MySQL/MariaDB version is (delete as applicable): MySQL/MariaDB version MariaDB10.5

Updating/Installing Errors
I am (delete as applicable): Updating
Upgrading/installing via (delete as applicable) : Web (use GitHub - virgilwashere/mautic-cron-commands: Script to run Mautic commands from a web page.)

These errors are showing in the installer :none

These errors are showing in the Mautic log :none

Your problem
My problem is :
Updated Mautic3.2.4 to 4.4.11.
After that, the following phenomenon occurred.

Anonymous contacts are recorded
An anonymous contact passes the form and is registered as a named contact.
Only form passing events are recorded for named contacts.
Anonymous contact information remains anonymous contact information before passing the form
Even if you visit the website afterwards, it will be recorded as an anonymous contact event.

In other words, contacts have been divided into anonymous and named contacts.
Of course, contacts are operated in one browser.

Correctly, I understand that the anonymous contact’s information will be integrated into the named contact as soon as the form is passed.
Mautic error log and server error log are empty.
What should I do now.

Steps I have tried to fix the problem :
I tried checking the error log, but nothing was written there.

1 Like

Here are some steps you can take to troubleshoot and potentially resolve the problem:

Check configuration
Ensure that your configuration settings are correct, especially those related to tracking and contact merging.
Verify that the “Override Contact” setting in the form configuration is set appropriately.

Database integrity:
Check the integrity of your database. Ensure that there are no issues with tables or indexes.
You may want to run Mautic’s built-in database consistency checks or repair commands.

Clear cache:
Clear the Mautic cache to make sure that any cached configurations or settings are updated.

Check form configuration:
Review the form configuration in Mautic and make sure that it is set up to identify and merge contacts correctly.

Review code changes:
If you’ve made any customizations or code changes during the update process, review them carefully. Incorrect modifications can lead to unexpected behavior.

Enable Mautic’s debugging mode to gather more information. This might provide insights into what’s happening during the contact merging process.

Rollback (if possible):
If the issue started after the update, consider rolling back to the previous version (if possible) to see if the problem persists. This can help isolate whether the issue is related to the update or another factor.

Always make sure to back up your instance and database before attempting any major changes or updates.

Thank you for answering.

I deleted the cache directory but nothing changed.
I enabled debug mode, but no errors were output.
I could not find the “Override Contacts” item on the form configuration screen. Is the Form Setting in /s/config/edit correct?
I tried /s/update/schema for Database integrity, but the message “The database schema is already up to date.” was displayed. How should I use the repair command?
The form settings remain unchanged from before the update. I made sure that kiosk mode was turned off.
No particular code modifications were made.

This is an update in a test environment, and Mautic in the production environment is still v3.2.4, so I checked again.
I was able to reproduce the same issue using private browsing, but contacts were correctly overwritten using a regular browser.
In 4.4.11, it will not be overwritten whether it is private or not.

Can you check if you have javascript errors in your browser when displaying or submitting the form?

Is Mautic and the site you are tracking the same domain?

There were no console errors before or after submitting the form.

Mautic and the website are separate domains.
This also applies to the production environment.
Domain restrictions were enabled in the settings, so I disabled them, but the problem did not change.

Are you sure Chrome is not blocking it?
Maybe you can use a CNAME to bring them to the same domain.
Is this Mautic 5?

This is an issue with 4.4.11.

I tried using another browser, but it didn’t resolve the issue.
I tried Chrome on multiple PCs, so it doesn’t seem to be an extension problem.

Is it a problem that the domains are different? I don’t want to edit DNS record settings.

What I meant is reading cookies from other domains might be blocked for you.
This is why contacts are always acknowledges as new and not merged.

I see.
I want to verify that possibility, how should I verify it?

Can you check if there is a cookie with mtc_id when you visit the page in question?

Check a page, then check the page where your form is located. Is the mtc_id the same?

I’m using this in chrome:

The cookie was as follows.

Name value Domain
mautic_device_id yxw5ptsnnhy92ez64xtbl24 Website
mautic_device_id rqatugz1dq9xtbjbkn6nzhe Mautic
mtc_id 334643 Mautic
mtc_id 334613 Website
mtc_sid yxw5ptsnnhy92ez64xtbl24 Website
mtc_sid rqatugz1dq9xtbjbkn6nzhe Mautic

Cookies existed on both the website and the Mautic site.
Could this be because they were all different?

However, I think there are other reasons why the contacts are not overwritten even after submitting the form.

Does anyone have any workaround?