Mautic Community Forums

Form submission results showing different data than what was entered

I’m testing to make sure forms on web site work properly. The form submission results like first name, last name, email do not match what the user entered.

If I view the contact, the data does in fact match what the user entered, i.e. the data stored w/the contact is correct but the form results show different data.

I’m testing from my own machine so perhaps something to do w/tracking, and I’m using a WordPress site w/Contact Form 7 and CF7 Mautic plugin to integrate forms. The form data shown doesn’t match any previous contact, i.e. I’ll enter bobtest20 as first name on site but form results will show bobtest9 and contact is correct w/bobtest20.

Any ideas?

Thank you!
Bob H.

Hi @mxyzptlkfishstix :

Thanks for your help. I tried from another computer, clearing the cache first, but same issue.

Maybe related to the CF7 Mautic plugin? But since the contact is added to Mautic w/correct data I wouldn’t think so. Only the form shows incorrect data for the submission, which is quite a big issue since form actions like adding points, adding to segment, etc. are not applying to the correct contact. Funny thing is, the contact shown by the form doesn’t even exist as a Contact anymore (they did prior but I deleted the old test users). Must be a table in the dB for form submissions that is separate from Contacts table, ya? On a side note, the email that I have Contact Form 7 sending out has the correctly entered data.

In my Tracking cfg., I have:
Identify visitors by IP: NO
Identify visitor by device fingerprint: YES
Identify visitor by tracking url: YES

Now another issue popped up in the last day. I have a segment (broadcast) email. For the past few weeks, when adding contacts to the segment, the email would update w/the new contacts so I could send the email to them. As of yesterday, it stopped updating. All the Cron jobs are running but don’t think a Cron job handles this, or does one of them? Any idea what might have caused this behavior?

Thanks,
Bob H.

I cloned the form and re-cfg. the CF7 Mautic plugin to use the new form and it’s working as expected. I guess we can consider this issue resolved but scary, no idea what caused the orig. form to have a mind of its’ own when recording submitted data.

Got it, thanks. If it happens again, I’ll try clearing the WordPress cache as a troubleshooting step. I had tried clearing the Mautic cache but that didn’t solve it.

I also had this issue, and here is what I found and how I solved:

  • Al those users that appear in the form, are users that you tried before and then you delete.

  • When you delete a User in the form in mautic, its not deleted from the database, you can see by looking the table of that form, something like prfix_form_results_1_name_of_form

  • If you check the logs of mautic in app/log, you will probably found something like:
    mautic.CRITICAL: Uncaught PHP Exception Doctrine\DBAL\Exception\UniqueConstraintViolationException: “An exception occurred while executing ‘INSERT INTO mkt_form_results_1_ecommerce (referralname, referralemail, referralposttitle, referralreferrer, submission_id, form_id) VALUES (?, ?, ?, ?, ?, ?)’ with params [data removed]: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘1’ for key ‘PRIMARY’” at /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php line 66 {“exception”:"[object]

Which as far as I understand is teling that is trying to save the user but there is already a entry “1”

How I solved?
Truncate the table of the form, and stop deleting the users created for tests (Warning: when you truncate the table of the form it will delete all the users/contacts of that form).

So my question is:

Is there a bug in Mautic that doesn`t delete the contacts of the form in the database when is deleted from the admin panel?

@Nestor what PHp Version ?

Hi @bizcrony,

The PHP version is: PHP Version 7.1.17-1+0
(hosted at Cloudways)

Downgrade the PHP to 7 not 7.1

Just tried with PHP 7.0 and that doesn`t solve the issue, if you delete a user from a form in the Mautic panel, it will remain in the table of that form.

Oh this is an cache issue, delete cache and update schema

It was a new Mautic setup (so no cache issue)
But I will just leave it at that, hopefully someone at the Mautic Dev team will find this.

Thanks!

Hope So