Mautic Community Forums

Help with new installation 2.8+

I’m trying to setup a fresh install of Mautic 2.8.1 on a TurnKey LAMP appliance which runs Debian Jessie. I believe I have met all the prerequisites for a clean install, but after the installation is complete, only two plugins, OneSignal and Twilio, are present. When I click on ‘Install/Upgrade Plugins’ the following two errors appear in the logs.

Code:
[2017-05-17 16:18:47] mautic.ERROR: PHP Notice: Cannot redeclare class MauticCoreBundleEntityCommonRepository - in file /var/www/mautic/app/bundles/CoreBundle/Entity/CommonRepository.php - at line 32 [] [] [2017-05-17 16:18:47] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: Cannot redeclare class MauticCoreBundleEntityCommonRepository - in file /var/www/mautic/app/bundles/CoreBundle/Entity/CommonRepository.php - at line 32 [] []
I've tried clearing the cache and restarting everything, but just get the same two errors repeating each time I try to install/upgrade plugins. I've tried both version 2.8.0 and now 2.8.1.
I'm following the guide by LinuxBabe here:
Code:
PHP Version 5.6.30-0+deb8u1 System Linux mautic 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 Build Date Feb 8 2017 08:50:48 Server API Apache 2.0 Handler
I'm new to using Mautic, so any help would be greatly appreciated. Thanks

I’m trying to setup a fresh install of Mautic 2.8.1 on a TurnKey LAMP appliance which runs Debian Jessie. I believe I have met all the prerequisites for a clean install, but after the installation is complete, only two plugins, OneSignal and Twilio, are present. When I click on ‘Install/Upgrade Plugins’ the following two errors appear in the logs.

[2017-05-17 16:18:47] mautic.ERROR: PHP Notice: Cannot redeclare class MauticCoreBundleEntityCommonRepository - in file /var/www/mautic/app/bundles/CoreBundle/Entity/CommonRepository.php - at line 32 [] [] [2017-05-17 16:18:47] mautic.ERROR: SymfonyComponentDebugExceptionFatalErrorException: Notice: Cannot redeclare class MauticCoreBundleEntityCommonRepository - in file /var/www/mautic/app/bundles/CoreBundle/Entity/CommonRepository.php - at line 32 [] []
I’ve tried clearing the cache and restarting everything, but just get the same two errors repeating each time I try to install/upgrade plugins. I’ve tried both version 2.8.0 and now 2.8.1.
I’m following the guide by LinuxBabe here:

PHP Version 5.6.30-0+deb8u1 System Linux mautic 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 Build Date Feb 8 2017 08:50:48 Server API Apache 2.0 Handler
I’m new to using Mautic, so any help would be greatly appreciated. Thanks

No clue my man, I use Ubuntu 16.04 and PHP7.

Have you considered the free hosted version at http://mautic.com?