Mautic Community Forums

How do I create an email sequence for contacts within a given segment

Please I need help How do I create an email sequence for contacts within a given segment.



I am using the thrive leads API it dumps my leads into a segment. I need to be able to

send a follow up email to the users on that list I cant seem to do that becasue

API is dumping it into my segment without a form created by me.

So I do not have a form to create the campaign that will kickstart my email sequence.



Can someone please help

Please I need help How do I create an email sequence for contacts within a given segment.

I am using the thrive leads API it dumps my leads into a segment. I need to be able to
send a follow up email to the users on that list I cant seem to do that becasue
API is dumping it into my segment without a form created by me.
So I do not have a form to create the campaign that will kickstart my email sequence.

Can someone please help

You don’t need a form; you can create a campaign using a segment as the source.

Can you please elaborate. I created a campaign using “page visited” triggered off my thank you page. But I am running into pixel tracking issue. I installed the pixel tracking plugin , i verified my thank you page has mtrackinf.gif on it, but it still does not show that the page was visited in mautic

Any help will be appreciated a link with detailed information will be great

My apologies, but your first post and second post sound like two different problems. Could you please clarify how your contacts are created, placed into a segment, and how you’ve created the campaign?

Here’s the link for campaign builder instructions:
https://mautic.org/docs/en/campaigns/campaign_builder.html

I’m not sure why (or how) you’re creating a campaign using ‘page visited’. You can select either a form or a segment as a source.

Thanks you for the response. Creating a campaign I can do that but making the campaign work …
http://screencast.com/t/fbwTtVm8Tr

The thrive theme api automatically places my contact into a segment in mautic using their own forms.

All I am trying to do is set up a follow up email sequence for users that have been placed into a segment by thrive themes API.
I am finding it difficult to send email after a user has been placed into the segment.
The system is not sending the email becasue the condition I have is send email when the user visits the thank you page.
Mautic campaign dashboard indicates that the thank you page was not visited “0 visits”
I have followed instruction with mautic tracking pixel installation.

So is there another way to set up an email sequence for users placed in a segment by API.

Now within mautic campaign here are my options
“Decision” “Action” & “Condition”

“Action” & “Condition” - not applicable at this stage and what I am looking to achieve.

For “Decisions” here are the options
Request Dynamic Content - NA
Submits Form - NA - because the API automatically places the contact into a segment without a form I have access to
Visits a Page - This can be use - I can say if the user goes to the thank you page then send the first email in the sequence
I am finding this option difficult becasue the tracking pixel is not working

Is there a simple way to create a follow up sequence from a segment? with out using the pixel
Or do I have to go back to the old way of using forms and ignoring the API?

Thanks

The only things that is close i

I’m sorry, but again can’t quite understand what you’re trying to do.

You ask if there’ a way to create a follow up from a segment, but you’ve already built a campaign using the segment that the API is creating. You can use the same process if the segment is created from a form.

Why is an Action not appropriate for your first step - isn’t sending an email what you want to do?

For your tracking pixel issue, could you please check your browser console (shortcut is usually F12) and see if there’s any errors coming up when the thank you page is loading.

Thanks Elenchus but this does not help I will use a weber instead truthfully this is a waste of time. I have wasted 2 days on basic set up that any auto responder does.I need to move on this is not worth my time a big waste

I’m sorry to hear that mate, but from what you’ve said I do think that most of your problems are user error rather than inherent issues with Mautic.