Mautic Community Forums

How to determine if Cron jobs running properly

Hi:

I installed Mautic last week and added the required Cron jobs, plus a couple of optional ones. But how do I determine if they’re running properly? I don’t see any entries about running the Cron jobs in the Mautic log at System Info > Log.

For example, I enter php /home/x3it0r296yej/public_html/app/console mautic:campaigns:update and select to be emailed when job runs. The email shows:

Mautic version 2.12.2 - app/prod

Usage:
command [options] [arguments]

Options:
-h, --help Display this help message
… (more options)

Available commands:
help Displays help for a command
list Lists commands
… (more commands)

The content of this email looks to me as if the command was run with ? parameter to provide info. about the command as opposed to actually running it. If run, I’d think I’d see something like the list of Campaigns updated, or a message like ‘No campaigns required to be updated’

Thanks for any insights!

CRON jobs are logged on you (Unix/Linux) host, not in Mautic. Does your mentioned statement “php…” run successfully in the console?

Hi @PeterTL:

Thanks for the tip. If I run the Cron job command from the console it’s working. The exact same command entered in my cPanel doesn’t run. Guess I need to follow-up with my host.

Thanks,
Bob H.

Turns out that with my host, I must use php-cli when entering the command in the Cron job scheduler, e.g. php-cli /path/to/mautic/app/console mautic:segments:update

Found this info. in the Mautic documentation on Cron jobs. Guess I need to read the doc. more!

Wouldn’t have guessed that solution - I am using php (with no cli). But good that it works now.

Hi @AmauticUser

Got it, thanks!

I think --env=prod is no longer required as of version 1.1.3, ya, at least that’s what the documentation says at https://mautic.org/docs/en/setup/cron_jobs.html.

I need to create those logs!

Thanks again,
Bob

Just wanted to add that I’m on A2 Hosting and this solved my problem.

I’m running over at Site5 on a Linux shared server and running PHP Version 7.0.7 and this is what error I keep getting.

PHP Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in /home/usr/public_html/mautic/app/bundles/EmailBundle/EventListener/ProcessReplySubscriber.php on line 26

Now, line 26 shows this:
const CACHE_KEY = self::BUNDLE.’_’.self::FOLDER_KEY;

Any idea of what is wrong? I asked my host just now and this was their reply: “The error which you are receiving is due to the scripts you are using, please contact your developer to fix it”.

I’m so lost in the sauce right now.

1 Like