How to install Acquia's Custom Objects plugin?

Check the admin menu first (right side)

1 Like

@joeyk :smiley:

When I was very very young and started off in the hi-tech world I was always quoted with RTFM…

Read The &*())&& Manual. I should have remembered this.

I looked for the menu for 1 hour before I found it. :smiley:
Mautic made me a better person: patience, resilience, scrutiny.

(Then I posted in the forums about lack of API docs. Made fool of myself. You can find it in the plugin’s wiki page :smiley: )

J

So back at this again.

We have an install that we just upgraded to 4.3.1 and I went ahead and followed the directions as explained above by @gary.harrison - Thanks!!

These directions worked very well for me on a clean install, however here I am getting an 500 Internal Error " Uh oh! I think I broke it. If I do it again, please report me to the system administrator!" message after installing the plugin and also with adding the PR mentioned by @escopecz .

I have looked to see if I can see any logs in mautic.error - nothing showing up on tail there.

I have made sure to chown the entire directory.
Cleared the cache.
Ran the command:

php console mautic:plugins:install
0 new plugins were installed and 0 updated.

Where else can I look to debug this ?

I basically re-ran the plugin:install again and it all worked!

3 Likes

Thx for sharing the solution here, this is great help for others!

Tried installing this now on latest manual install of 4.4.4 and got the following error:

HP Fatal error:  Uncaught Error: Interface 'Mautic\CoreBundle\Entity\UpsertInterface' not found in /var/www/ams/plugins/CustomObjectsBundle/Entity/CustomItem.php:45
Stack trace:
#0 /var/www/ams/vendor/composer/ClassLoader.php(571): include()
#1 /var/www/ams/vendor/composer/ClassLoader.php(428): Composer\Autoload\includeFile()
#2 [internal function]: Composer\Autoload\ClassLoader->loadClass()
#3 [internal function]: spl_autoload_call()
#4 /var/www/ams/app/bundles/CoreBundle/DependencyInjection/Builder/Metadata/EntityMetadata.php(55): ReflectionClass->__construct()
#5 /var/www/ams/app/bundles/CoreBundle/DependencyInjection/Builder/BundleMetadataBuilder.php(164): Mautic\CoreBundle\DependencyInjection\Builder\Metadata\EntityMetadata->build()
#6 /var/www/ams/app/bundles/CoreBundle/DependencyInjection/Builder/BundleMetadataBuilder.php(158): Mautic\CoreBundle\DependencyInjection\Builder\BundleMetadataBuilder->buildMappings()
#7 /var/www/ams/app/bundles/CoreBundle/DependencyInjection/Builder/BundleMetadataBuilder.php(116): Mautic\Cor in /var/www/ams/plugins/CustomObjectsBundle/Entity/CustomItem.php on line 45

Any ideas?

I could be wrong here… but try installing mautic dev dependencies.

Sorry about this. The plugin is developed by Acquia that have different release cycle than the community. You have to manually insert this new class:

or wait for Mautic 5 release. That PR could be also cherry-picked to a new pull request for Mautic 4 if someone would want support for Mautic 4.

Maybe we can add to 4.4.5 ?

I asked the author of the PR to create the PR for M4 too.

1 Like

Hi @escopecz thanks for jumping in here.

So I have gone ahead and done the following:

  1. Amended the file CommonRespository.php
  2. Created the two new files UpsertInterface.php and UpsertTrait.php
  3. I created phpstan.neon in the mautic root directory.

Reinstalled the plugin and seems to have worked and got installed.

Appreciate this.

And the author prepared the PR for Mautic 4. I’ve made a review and will be merging it shortly. So Mautic 4.4.5 will support the latest Custom Objects plugin version.

Amazing :smiley: