Hubspot API, Mautic 4.4.5. Old invalid key in database loops to 500 error

Your software
My Mautic version is: 4.4.5
My PHP version is: 7.4.32
My Database type and version is: 10.4.26-MariaDB

Your problem
I think I have stored an invalid key in the field API key field and/or in the new private app field of the Hubspot plugin. As a result when opening the plugin it hangs on loading and the log shows error 500.

I don’t use 0Auht2.

I suspect the protected function from verifying if the API stored is valid and then returning an error but not providing an option to store a better one.

These errors are showing in the log: 500

Steps I have tried to fix the problem:
See Fix/change hubspot api auth by npracht · Pull Request #11470 · mautic/mautic · GitHub
Tested in firefox and chrome
tried the chrome console

Hi, I have the same problem on Mautic 4.4.5.
Did you manage to solve it ?

Not yet.

How is your hosting capacity? Does it take long to login to Mautic?
Do you have custom fields and where they mapped before in the Hubspot API?
I hope I will get access to the database to force the key in there and/or remove previous field mappings.

Unfortunatilly a Gitpod loads the 5.0 version and the Hubspot API updates are not in there yet. Hence I can’t verify if the key produces by Hubspot is accepted by Mautic

I do see error from symfony forms:
A form with an empty name cannot have a parent form." at /var/www/html/mautic/vendor/symfony/form/Form.php line 284

Do you get that error?

Yes It takes a long time to connect, but I think it’s not rapport with plugin Husbpot, just server is slow.
I don’t have informations for custom fields (I took over Mautic a short time ago).

In contract, I resolve the problem when I remove the key directly on the database on the table “plugin_integration_settings”. Thank you for idea :wink:

And yes, I had the same error when I tried it to connect !

This was my solution / workaround

In de databse table “plugin_integration_settings” I copies the content of the three fields into a .tct file and saved it. I disabled the plugin by replacing the 1 with 0 in field is_published.
I replaced the content in the next fields with:




Save the changes in the database by clicking go.

Next go into Mautic plugin hubspot and add the key and save.
I got a 500 error again but by savin& closing and reopening again i progressed step by step.

Then I went back to the database and put the old content back of field Feature setting. (restoring fieldmappings.

Now in hubspot at the private app I see API calls.

What I did find strange is that in de Gitpod Dbase the ID of hte Hubspot plugin differs from my database. Furthermore in the Gitpod database there are two tables for Hubspot (And other plugins)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.