Mautic Community Forums

I am not able to install Mautic 3.0 via FTP - problem with permissions?

Your software
My PHP version is : 7.3.19-1+0~20200612.60+debian9~1.gbp6c8fe1
My MySQL version is: 10.1.44-MariaDB-0+deb9u1 - Debian 9.11

Installing Errors
I am installing: Mautic 3.0
Installing via: web (FTP)

These errors are showing in the installer :

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

System administrators, check server logs for errors.

These errors are showing in the Mautic log :
I don´t know where is the Mautic log exactly, but there is no log in the var/logs and no errors on the server

Your problem
I am not able to install Mautic 3.0 via FTP

Steps I have tried to fix the problem :

I followed these instructions https://docs.mautic.org/en/setup/getting-started , but I didn´t know, how to change the permissions (I am not a programmer or developer), so I asked my VPS provider to do it, they did it but the error still persists. We have noticed that the dictionary structure is different than in the instructions.

Thank you for your help

Hi there,

As a starting point:

You need to update your MariaDB version.

Please see the minimum requirements here: https://www.mautic.org/download/requirements - 10.2 is the minimum for Mautic 3.x.

Hi, I can´t confirm if this was the cause, because I would have to migrate to a new server to update the MariadDB which I am not gonna do anytime soon, so I am gonna stick with the old version of Mautic for now. Anyway thank you :wink:

1 Like