I can't access mauitc anymore

Your software
My Mautic version is: 4.2
My PHP version is:
My Database type and version is:

Your problem
My problem is:
from one moment to another, this message appeared when I wanted to enter mautic:

The site is currently offline due to encountering an error. If the problem persists, please contact the system administrator.

These errors are showing in the log:
console.CRITICAL: Error thrown while running command “‘campaigns:update’”. Message: “There are no commands defined in the “campaigns” namespace. Did you mean this? mautic:campaigns” {“exception”:“[object] (Symfony\Component\Console\Exception\NamespaceNotFoundException(code: 0): There are no commands defined in the "campaigns" namespace.\n\nDid you mean this?\n mautic:campaigns at /opt/bitnami/mautic/vendor/symfony/console/Application.php:604)”,“command”:“‘campaigns:update’”,“message”:“There are no commands defined in the "campaigns" namespace.\n\nDid you mean this?\n mautic:campaigns”}

Steps I have tried to fix the problem:
I cleared cache and deleted the cronjob but none of this worked,
Can somebody help me please?

Hi, those errors refer to your cronjobs. They are most likely wrong. You can post them here so we can help you.
What happens if you try to run (in your mautic folder via ssh) php bin/console cache:clear

1 Like

thanks for your answer, My cronjobs are currently like this, I’ve been working like this for over a year, I already deleted the cornjobs and cleared the cache to see what happened and it’s still the same

0,15,30,45 * * * * sudo php /opt/bitnami/mautic/bin/console mautic:campaigns:update

5,20,35,50 * * * * sudo php /opt/bitnami/mautic/bin/console campaigns:update

10,25,40,55 * * * * sudo php /opt/bitnami/mautic/bin/console campaigns:trigger

3,18,33,48 * * * * sudo php /opt/bitnami/mautic/bin/console mautic:emails:send

0 0 * * * sudo /opt/bitnami/letsencrypt/lego --path /opt/bitnami/letsencrypt --email=“paranda@arsenweb.com.mx” --http --http-timeout 30 --http.webroot /opt/bitn$

Above is not correct, you need:
5,20,35,50 * * * * sudo php /opt/bitnami/mautic/bin/console mautic:campaigns:update
10,25,40,55 * * * * sudo php /opt/bitnami/mautic/bin/console mautic:campaigns:trigger

When you clear the cache, make sure you do it with the right user.
Bitnami can be tricky, I’m not sure which user they want you to run Mautic with.

I’ve always cleared the cache with my username, and I hadn’t had any problems, technically I’m not good at linux at all, do you think you can give me a quote and I’ll give you the access so you can help me solve my problem?

Hi, I take a look for free, just send me ssh access in private.

I already shared it with you, thank you