I can't access the configuration page on my mautic install. When I try to access s/config/edit page. I get a 500 error

Your software
My Mautic version is: 3.3.2
My PHP version is: 7.4
My Database type and version is: MySql 15.1

Your problem
My problem is: I can’t access the s/config/edit page. I get a 500 error. I checked the logs. No errors. I checked permissions. Permissions are good. I need help. Please! All the other pages work fine.

These errors are showing in the log: no errors in logs

Steps I have tried to fix the problem: I set permissions. cd $MAUTIC_HOME

mkdir app/spool/

find . -type d -exec chmod 755 {} ;

find . -type f -exec chmod 644 {} ;

chmod -R g+w app/cache/

chmod -R g+w app/logs/

chmod -R g+w app/config/

chmod -R g+w media/files/

chmod -R g+w media/images/

chmod -R g+w translations/

chmod -R g+w app/spool/

chmod -R g+w themes

chown -R mautic:mautic .

console cache:clear via ssh

I tried that. I tried manually clearing var/cache/* as well. I click on gear. It never opens the configuration page s/config/edit page. I will get 500 error. No errors in the logs I can see.

The only error I see is an FCGID warning about the time I am trying to access the configuration page.
I tried to google that error message. Nothing comes up.

[Sun Apr 11 21:44:49.355784 2021] [fcgid:warn] [pid 17774] mod_fcgid: process 2191 graceful kill fail, sending SIGKILL

[Sun Apr 11 21:47:07.985892 2021] [fcgid:warn] [pid 17774] mod_fcgid: process 2729 graceful kill fail, sending SIGKILL

[Sun Apr 11 21:47:13.991082 2021] [fcgid:warn] [pid 17774] mod_fcgid: process 2730 graceful kill fail, sending SIGKILL

I fixed the issue by zeroing out the data in the local.php file for monitored mail. That was the last change I made to the configuration. Once I zero’d out these values. Configuration page is accessible again. Not sure if this is a bug or not.‘monitored_email’ =>
array (
‘general’ =>
array (
‘address’ => ‘’,
‘host’ => ‘’,
‘port’ => ‘’,
‘encryption’ => ‘’,
‘user’ => ‘’,
‘password’ => ‘’,
‘use_attachments’ => ‘’,
),