Config page not loaded anymore

Your software
My Mautic version is: 3.1.2
My PHP version is: 7.3

Your problem
When i try to access the configuration page (wheel icon) i only see the progress bar but the page does not show up. It had worked for a while, but for an unknown reason it does not do anymore.
What may be special in our setup is that we use Mautic behind an Nginx reverse proxy doing SSL termination and forwards to Mautic via HTTP. We had some issues to get this working. After we find a bugfix in your Github to add “$_SERVER[‘HTTPS’] = ‘on’;” into index.php it seem to work from the first. But only the setup-page isn’t accessible anymore.

These errors are showing in the log:
In the Apache2 error log i see:
[Thu Nov 05 10:21:37.937539 2020] [core:notice] [pid 24522] AH00052: child pid 24524 exit signal Segmentation fault (11) [Thu Nov 05 10:22:38.003360 2020] [core:notice] [pid 24522] AH00052: child pid 24525 exit signal Segmentation fault (11)

And in the vhost Apache2 errorlog:
[Thu Nov 05 10:00:09.303159 2020] [php7:error] [pid 24525] [client xx.xx.xx.xx:35974] PHP Fatal error: Uncaught TypeError: Argument 3 passed to Monolog\\Logger::log() must be of the type array, null given, called in /systems/mautic/htdocs/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php on line 424 and defined in /systems/mautic/htdocs/vendor/monolog/monolog/src/Monolog/Logger.php:610\nStack trace:\n#0 /systems/mautic/htdocs/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php(424): Monolog\\Logger->log('notice', 'PHP Notice - Un...', NULL)\n#1 /systems/mautic/htdocs/app/bundles/CoreBundle/ErrorHandler/ErrorHandler.php(173): Mautic\\CoreBundle\\ErrorHandler\\ErrorHandler->log('notice', 'PHP Notice - Un...', NULL)\n#2 [internal function]: Mautic\\CoreBundle\\ErrorHandler\\ErrorHandler->handleError(8, 'PHP Notice - Un...', 'Unknown', 0, NULL)\n#3 {main}\n thrown in /systems/mautic/htdocs/vendor/monolog/monolog/src/Monolog/Logger.php on line 610, referer:

In the var/log/mautic…php you find:
[2020-11-05 11:39:45] mautic.CRITICAL: Uncaught PHP Exception Symfony\Component\Debug\Exception\FatalErrorException: "Compile Error: require(): Failed opening required '/systems/mautic/htdocs/var/cache/prod/ContainerYucvmqw/getRouting_LoaderService.php' (include_path='.:/usr/share/php')" at /systems/mautic/htdocs/var/cache/prod/ContainerYucvmqw/appProdProjectContainer.php line 5846 {"exception":"[object] (Symfony\\Component\\Debug\\Exception\\FatalErrorException(code: 0): Compile Error: require(): Failed opening required '/systems/mautic/htdocs/var/cache/prod/ContainerYucvmqw/getRouting_LoaderService.php' (include_path='.:/usr/share/php') at /systems/mautic/htdocs/var/cache/prod/ContainerYucvmqw/appProdProjectContainer.php:5846)"} []

Steps I have tried to fix the problem:
Deleting the cache in var/cache/ (had rebuild after first page access)

child pid 24524 exit signal Segmentation fault

Try increasing PHP memory limit in php.ini to more than 512mb. It appears that your server is running out of Memory while loading the Config page.

@imog Have you resolved the issue with your config page not loading from the Gear icon?