/mailer/amazon/callback is not working - 404 error

Your software
My Mautic version is: 3.0.1
My PHP version is: 7.3.20

Your problem
My problem is: I’m trying to setup Amazon SNS to remove bounce emails but my signature is still pending. I’m using a Hostgator VPS.

These errors are showing in the log: loudWatch Logs below

“notification”: {
“messageId”: “4f1f66a3-6f51-4c27-8473-de9d03bf9c35”,
“topicArn”: “arn:aws:sns:us-east-1:600022727559:Mautic”,
“timestamp”: “2020-07-20 22:44:24.669”
“delivery”: {
“deliveryId”: “204ab559-2ae3-5004-8df9-e2c90a6babbe”,
“destination”: “https://clicklink.turbox.me/mailer/amazon/callback”,
“providerResponse”: “Not Found”,
“dwellTimeMs”: 645,
“attempts”: 1,
“statusCode”: 404
“status”: “SUCCESS”

Steps I have tried to fix the problem: I tried to change the port and disable CloudFlare

When I disable the Cloudflare’s SSL/TLS the status code change to 301.

I was using ‘Another SMTP server’ and the port 2587 was blocked.
I changed to AMAZON SES service and change the port to 587 on code.

I have this same issue but I had to configure as Another SMTP Server because my server location is not under the Amazon SES dropdown. Any ideas?

I just switched the region to one of the supported dropdown options in Mautic and resolve the problem. This issue should perhaps make the option of servers accept manual input for Amazon SES.

I am also having the same issue with the call back /mailer/amazon/callback its not working for me for SNS

Edit: I was digging around and found a solution which is mentioned here

If you use Amazon SES API you must include the call back with amazon_api /mailer/amazon_api/callback