Mautic Community Forums

Mautic 4.1.1 fresh installation stuck on Step 1,1 - Database configuration

Your software Mautic 4.1.1
My PHP version is : 7.4
My MySQL/MariaDB version is (delete as applicable): MariaDB version 10.6

Updating/Installing Errors
I am (delete as applicable): Installing
Upgrading/installing via (delete as applicable) : Web

These errors are showing in the installer : no errors

These errors are showing in the Mautic log : no errors

Your problem
My problem is : that the Installer gets stuck in Step 1,1 asking for SQL database credentials. Once populated, the /app/config/local.php file is created with my credentials and db info, but it never proceeds to the next step, just keeps refreshing step 1,1 no matter what I do.

Steps I have tried to fix the problem :
I can’t force it to go to step/2 or step/3 either
trying to change the URL to step/4 results in an error in the logs & on the page

Trying to use invalid db credentials results in an error message on the step/1,1 page so it’s attempting to connect to the SQL db and succeeds with that but it never creates any tables in the database - it’s empty.

Tried to delete the var/cache folder, recreate a new database… nothing helps.

The only thing that appears to work is linking to an existing SQL db from another instance, but that one is using version 3.x so the tables are not quite compatible - but at least I’m able to log-in …
However I couldn’t display the list of contacts, until I tried running /s/update/schema which has failed with many error log entries, but some functionality started to work … other functions keep on failing…

How to install mautic 4.1.1 from scratch? How to get out of Step 1,1 (database configuration) ???

This is soooo annoying.