Mautic 5.0.3 AWS SNS endpoint is not working. GIve a solution to handle bounce and Complaint emails

Your software
My Mautic version is:5.0.3
My PHP version is:8.1
My Database type and version is: Mysql 8.0.36

Hi Mauitc Aws Sns endpoint is showing pending confirmation. What is the correct endpoint URL.

Please provide a solution how to handle bounce and complaint rate without SNS.


One of the solutions:

Remember: Google is your friend

1 Like

The other solution, using implementation from above: GitHub - mzagmajster/mautic-ses-plugin

Callback url is: /mailer/callback

For amazon ses? you are talking about right.

I have tried it but still its showing pending verification. can you tell me the exact format of the URL.

Hi, we have tried this method. Still, its showing pending verification in aws sns. Please provide a solution. Or else create a guide for this

Yes, this also works for me as well.

No email transport that could process this callback was found

this is whats its showing


Did you set up AWS already in Mautic?
Where is the error shown?

Its success.
I have downloaded the ses plugin from the git and renamed it.
I have created the sns subscription also as follows

I have tried all of them.

Please provide solution.

Where is this error shown:

“No email transport that could process this callback was found”

sns subscription is pending in aws. No confirming. what to do ?

Can you answer the previous question please?

Where do you see the error above?

In the web browser when i search the https://domain/mailer/callback
I get an error saying this.

Of course, that is normal.
Since you are opening that link and not posting a valid payload it will show that.
At least we cleared, it’s not relevant.

But I have tried the steps you have given, Still, the sns subscription is pending.


Make sure you are not using the main branch, but M5!!!

Then use:

If you go with my plugin

The callback is:

We have done it in Cpanel, downloaded the file renamed it, and set the endpoint in the sns. still no response. Do we have to do anything terminal? if yes, Please let me know what are the things need to be done.

Did you clear the cache?
Are the permissions okay?
Did you reload the plugins?

Thank you for your quick response.
Can you help with reloading plugins?


php %yourpath% bin/console cache:clear
php %yourpath% bin/console mautic:plugins:reload
php %yourpath% bin/console mautic:plugins:install

where %yourpath% is your mautic path
You need to execute these in SSH console, hopefully as a web user

1 Like