Mautic Community Forums

Mautic Http to Https

Hi guys i have a problem i just move all my sites to a https sites but im have problem with Mautic. the only way i can put Mautic to work in https is creating a new Mautic instance (using softlocus) and put https in the install wizard.

Hi guys i have a problem i just move all my sites to a https sites but im have problem with Mautic. the only way i can put Mautic to work in https is creating a new Mautic instance (using softlocus) and put https in the install wizard.

I will try!

So how was it?

this is a 2016 post is old all my Mautic have SSL

I am on it now ^^

I’m gonna try to put it with let’s encrypt get ready I may come back to you ahaha

Do you have easy advice to make it properly?

First I create the certificate.
Then I change the url from http to https in the settings panel
Then I delete the cache folder
And then I make new forms right?

yes

It looks easy ^^

Thx mate

Thanks for the above information it works perfectly no issues from going from http:// to https://

@MxyzptlkFishStix I am still getting too many redirect after setting this but when i did curl and my domain it shows this

<!DOCTYPE html>
<html>
    <head>
        <meta charset="UTF-8" />
        <meta http-equiv="refresh" content="1;url=https://m.mydomain.com/" />

        <title>Redirecting to https://m.mydomain.com/</title>
    </head>
    <body>
        Redirecting to <a href="https://m.mydomain.com/">https://m.mydomain.com/</a>.
    </body>
</html>

I see the exact same error.

Looking at the source files, it seems to have something to do with Symfony security. As the html provided when redirecting comes from there:

File: …vendorsymfonyhttp-foundationRedirectResponse.php

    /**
     * Sets the redirect target of this response.
     *
     * @param string $url The URL to redirect to
     *
     * @return RedirectResponse The current response
     *
     * @throws InvalidArgumentException
     */
    public function setTargetUrl($url)
    {
        if (empty($url)) {
            throw new InvalidArgumentException('Cannot redirect to an empty URL.');
        }

        $this->targetUrl = $url;

        $this->setContent(
            sprintf('<!DOCTYPE html>
<html>
    <head>
        <meta charset="UTF-8" />
        <meta http-equiv="refresh" content="1;url=%1$s" />

        <title>Redirecting to %1$s</title>
    </head>
    <body>
        Redirecting to <a href="%1$s">%1$s</a>.
    </body>
</html>', htmlspecialchars($url, ENT_QUOTES, 'UTF-8')));

        $this->headers->set('Location', $url);

        return $this;
    }

Hey guys, I’m still working on it. But I think I’m getting close.

My setup is:
Nginx 1.10.3
Digital Ocean Ubuntu 16.04.2 x64
Mautic 2.8.2 installed on a subdomain
I was using cloudflare for DNS, and installed their certificate with ‘flexible ssl’ option for https.

So the problem seems to be stated here:

On this article, they instruct to create a site rule, forcing https always on this domain., I tried that and didn’t fix the problem.

The only solution, for now was to turn off all the Cloudflare SSL/TLS Https setup and get back to plain HTTP on my server.

But maybe, Cloudflare https solution is not the way to go. Letsencrypt should give less problems.

Still working on this issue myself. I’ve made the changes to the two forms, made sure my site URL was https, cleared cache and rebuild form – still Please Wait. Only thing I noticed is in config I do not see an option to Set Cookies as Secure to change to yes.
Running mautic self-hosted on siteground with mautic 2.11.0 installed a few days ago. It’s in a folder from main domain, which is build in WP. Letsencrypt enable for the main domain.
Any suggestions or anyone with some expertise I could hire to fix it? Thanks! The URL to the form that’s not working is https://cynmobleylaw.com/nonprofit_ninjas/np1paydirectors

https:// for SSL isn’t in any versions after 2.8.0 2.8.2 doesn’t have it they removed it i don’t know why. I keep the old 2.8.0 zip file for clean installs to change over to https:// than i update to current version of mautic with no problems. That is how to fix anything it stupid why it’s no longer in versions 2.8.2 and newer

Thank you, @vcdesigns . I have downloaded 2.8.0. So you are saying that you install 2.8.0 on your https:// sites and then just run the updates to go to 2.11? Am I understanding that correctly?
Fortunately, I only have one campaign built so it wouldn’t be hat hard to redo everything. I’m assuming the db schema may have changed between 2.8.0 and 2.11 so I can’t just overwrite some files.
I have tried everything I’ve found on the boards, making sure to try it with incognito browser, and it’s just not working. I THINK it might be because it’s installed in a folder of the domain, but the recommended change in the js files isn’t working on 2.11.0.

once it’s installed, you have to change the settings in the confiruation area url address should be https://domainname.com than locate below that the cache settings change that to secure by clicking on yes, apply save and close, logout, than clear your browser history completely, than go back to your site login and than it should show in address bar https://domainname.com is green and secure. After that do update.