Mautic inaccessible - site is offline

Your software
My Mautic version is: 4.4.9
My PHP version is: 8.0
My Database type and version is: MySQL Version 8.0.33

Your problem
My problem is:
Mautic is inaccessible with the error message on “The site is currently offline due to encountering an error.” after transferring Mautic cpanel from old server to new Cloudlinux 8 server (using Cpanel’s TransferTool) then upgrade to version 4.4.9 via command line

These errors are showing in the log:
mautic.ERROR: INTEGRATION ERROR: APP - code does not have a value

Steps I have tried to fix the problem:

  • Clear cache in var/cache
  • run command line in terminal to clear cache
  • view in new incognitio mode
  • delete cookies

Hi, do you have extra plugins installed?

Hi @joeyk there is no extra plugins installed since May 2022, the following plugins were installed on May 2022:
Grapes JSBuilder
Mautic Recaptcha
Mautic Tag Manager

I noticed after upgrade via command line to 4.4.9 those plugins folders above seem not affected by the update whereas the other plugin folders shows “last updated yesterday”.

I hope this makes sense.

Hm, we need more logs I think

I would also advise to pack things in tar and transfer via scp instead of using third party tools.

Also if possible use dedicated server as oppose to shared hosting.

Hi Matic @mzagmajster ,
Thank you so much for your response and advice.
We actually use dedicated VPS server with CloudLinux 8 (new server)

  1. The problem with the manual zipping and transfer upload then modify the config setting is that the database file size is pretty huge (~5GB, probably due to size of tables mautic_email_stats, mautic_page_hits) affecting transfer time and likelihood of importing failure in database system.

  2. One of reasons I use CPanel’s TransferTool is because we have multiple add-on domains that we need to update DNS instantly for all domains for websites hosted in that cpanel account - with the time being in the factor into consideration.

Hi Joey @joeyk here is the log below for your reference.
[2023-06-05 00:00:48] mautic.ERROR: INTEGRATION ERROR: Vtiger - code does not have a value
I assume the Vtiger plugin for Mautic doesn’t support MySQL8 or PHP8 which caused the error?

Test it: Disable the Vtiger plugin (remove it from the plugins folder and clear cache).

re 1.) 5GB should be no issue with a VPS, if its sized to run Mautic
re 2.) You still could use another transfer as suggested. We also use Plesk but transfer with SCP standard protocol.


  1. If you create an archive that should reduce the size and time to transfer. Database of size 5 GB is not that big. I think you should be fine. Backup entire source & database (I would suggest using mysqldump from the CLI, but if you have a gui option it should also work).

  2. I do not know this tool in details but looks like @dirk_s offered some insight into that. Also you do not have to change the DNS until you setup everything on the new server. I imagine you can change the DNS via the interface and if you first setup everything in regards to source code and database, you will have hardly any down time.

Also the suggestion about Vtiger plugin from @dirk_s is worth checking out.

Regards, M.

Hi @dirk_s , I tried to remove Vtiger plugin and cleared cache, the issue still persists.
Is it possible to import SQL manually and update path in Mautic config, would it be guaranteed to run as normally?
I will see if I can use WinSCP to upload Mautic files and dump database file then run MySQL command line to import it provided if there is enough free space left in new server.

@mzagmajster thank you for your suggestion, I am working in local environment using host file to be safe just in the case.

Hi @dirk_s, just checking if you mean SCP is a WinSCP? We don’t have Plesk but only cloudlinux

Hi @duplexcleaning that was a comparison. Plesk is also a control panel on top of a linux server. However, I would also not use the built in file manager. But even with plesk I can use standard file transfer protocols, like ftp and scp. That was suggested earlier in the thread to use a standard file transfer instead of proprietary services provided by those control panels.

Also CPanel allows this: Using SCP – cPanel

Hi @dirk_s , thank you for that,
I was able to use shell access to run the scp command to copy the folder to the remote server,
However, there seems to be a disadvantage of using SCP, that is, the likelihood of getting a timeout prevented the process to resume or continue once the connection is re-established (for example, screen timeout, away for lunch, etc)

Would zip folder then scp to copy that zip file be recommended?

If you use SCP, you can also use SSH. Much better than FTP.
So you upload the zipped file, and then use the command line via SSH to unzip the file.

Hey duplexleaning

I would recommend: install a blank mautic 4.4.9 to the new server and when this works then copy the old database copy the other assets (media folder, form upload folder, themes …etc)


1 Like

thanks @sfahrenkrog1 , I will try that.

@dirk_s Interestingly there had been two occurrences where I used SCP to copy Mautic Zipped (tar file) and import databases in two different cpanel accounts.

A Mautic instance hosted in one cpanel account working in different domain name other than the original, whereas the Mautic instance hosted in another cpanel account that uses the same original domain address but in new server didn’t work well.

1 Like