Mautic Community Forums

Mautic-international-phone-input-bundle error to install

I am trying install this

But it is returning error:

Problem 1

  • mtcextendee/mautic-international-phone-input-bundle[1.1.0, …, 1.1.3] require mautic/composer-plugin ^1.0 → satisfiable by mautic/composer-plugin[1.0.0, 1.0.1].
  • mautic/composer-plugin[1.0.0, …, 1.0.1] require composer-plugin-api ^1.0 → found composer-plugin-api[2.0.0] but it does not match the constraint.
  • Root composer.json requires mtcextendee/mautic-international-phone-input-bundle ^1.1 → satisfiable by mtcextendee/mautic-international-phone-input-bundle[1.1.0, 1.1.1, 1.1.2, 1.1.3].

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

I tried install manually. but didn’t work.
How to solve?

Hi, I think this is not compatible with M3.

Very bad, becouse this is a great feature. Is there some similiar option?

Agree that this plug-in has served me well. I have a few others that we use that would need to be updated for Mautic 3.

this feature must be integrate mautic core. very usefull!

There is international phone validation as a default:

The reason why features not getting into the core is NOT because the evil lizard-men decide to remove it, but because there are resources missing to accomplish that.
If you can update this to M3, plz do so :slight_smile:

I Know there is a “validate as international format” option. But here in my country the people have problems to insert +55 after the number. The major of the people doesn’t know about international prefix. To use geolocalization to insert the international code resolve this problem.
Thanks a lot

as this is a custom plugin, you can always request the creator to update it.
At the same time, you can also use the validation error text to tell them: HEY, YOU NEED TO PUT +55 IN FRONT AS THIS IS INTERNATIONAL FORMAT! OBRIGADO!