Issue: Installing a new Plugin for first time

Hi Guys,

There might be an easy answer to this question, but I can’t figure it out! I am new to Mautic and I have been experimenting with to try and create more intelligent email segments on my Wordpress site. There is an exciting plugin I have found called:

The Mautic Recommender Plugin:

I have an installed version of Mautic live on my plesk server. I added the plugin to the Mautic plugins folder and could not figure out why there was no new plugin available within the plugins page when I opened Mautic.

Would greatly appreciate any support and advice to get past my road block!

Many Thanks,

Also I could not figure out what the instructions from the “docs.mtextendee” are asking because I am not a programer with much understanding of PHP.

Although I would like to figure out how I can install potentially other plugins in future …

This is not compatible with Mautic 3 and 4.
Make sure you are using the right version.

Ah ok, thank you joeyk,

Just wondered if if you have any advice about checking version compatibility…
How can I find out if a plugin is compatible?

I could not see with this plugin anything in the documentation or the readme file about version compatibility. Is there a place, or file directory where I could find this out in future?

Many Thanks,

I have tried to install these plugins as well without any luck…


Could there be another issue…
(to install I am unzipping them and inserting them into the plugins folder on my server installation)

Could an issue be that i’ve installed Mautic through Softaculous?

I think they are all M2 and M3 plugins. With 4.1 you’ll be able to install plugins with a click!

How to do that?
I am trying to install several custom plugins but they just don’t appear.

Sorry this feature is postponed to 4.2


I’ve tried installing GitHub - TheDMSGroup/mautic-contact-source: Creates API endpoints for receiving contacts from external sources. and GitHub - TheDMSGroup/mautic-contact-client: Create custom integrations without writing code, like having your own Zapier.

By downloading and expanding the folder under:

Then go to /s/plugins/reload but they are not installed, and do not show up.

I downloaded the stable versions of each, any ideas on what am I doing wrong?

I’m using Mautic 4.1.2 installed on Plesk


You are trying to install a Mautic 2 plugin for Mautic 4.
Won’t work. Not compatible.

Thanks for letting me know @joeyk !

Does this mean these are not available for v4? It is kind of misleading that they list these under Marketplace so it’s easy to assume the plugins there are compatible with the latest stable release :confused:

Hopefully v 4.2 is released soon with one-click plugins installations then :slight_smile: