Install Plugins

Hi, i´m new to Mautic. I tried to install plugins. When I click “install plugin” I get a message that 0 plugins have been installed. They also do not appear on the plugin overview page.
Many thanks for hints.

  • check that your plugins folder actually contains plugins
  • clear the cache using rm -rf var/cache/dev/* var/cache/prod/*
  • then run from terminal php bin/console mautic:plugins:reload --env=prod

Thank you very much. I tried this. But i still get 0 plugins updated/installed

What does this query shows:

SELECT * FROM plugins;

And still nothing shows on plugin page and plugin search dropdown? Can you check the permissions on plugins folder?

And finally clear the cache like above and try yet another command:

php bin/console mautic:plugins:install --env=prod

Hi, thanks much! The table is missing. The select shows “Table ‘xxxxxxxx.plugins’ doesn’t exist”

But i have a table mauticplugins. There i get the already installed plugins.

On the page and search dropdown i have the default plugins shown.

With “php bin/console mautic:plugins:install --env=prod” i get the same message: 0 plugins installed or updated.

I suspect every table is then prefixed with “mautic”? So instead of “plugins” table you have “mauticplugins”. Instead of “leads” you have “mauticleads”. Can you check if my assumption is correct?

And can you check what is the value of table_prefix key in app/config/local.php? Can you set it to correct prefix if not already (“mautic” most probably).

FInally can you double check that the name of the plugin bundle you are trying to install is correct?

After that, please clear the cache and reload the plugins again.

Regards, M.

Yes, all the tables has prefix “mautic”.

In local.php there is already " ‘db_table_prefix’ => ‘mautic’,"

How can i check for the right plugin bundle name? I unpacked the plugin (tried 2 plugins) and copied the directories and files to /plugins directory

Thanks much for you effort!

Hi, i don´t know what happen. Just tried clicking on update/install button and the plugin is installed?

What file and directory permissions do i need? I have dir 755 and files 640.

Not sure, did you manage to install the plugin?

Plugins need to follow naming convention set by symfony/mautic core. For example this plugin has to be cloned into plugins directory: GitHub - mzagmajster/mautic-mailgun-mailer-plugin: Mailgun Email plugin for Mautic with multi-domains support and plugin root directory must be MauticMailgunMailerBundle, what plugin(s) are you trying to install?

Permissions 640 should be fine although 644 is more common.

Thanks so much. I have no idea. I changed nothing and now i can update the plugins. It is possible to have issues with browser cache for that?

I am not sure, possibly. Glad to see you worked it out.

Thanks so much for your help !