Mautic/mautic:v4-apache -> mautic/mautic:5.0.3-apache

Your software
My Mautic version is: 4.4.1
My PHP version is: 7.4
My Database type and version is: powertic/percona-docker

Your problem
My problem is:

I am running off of the old example yaml that uses the above images. I tried updating via compose and i got an error that my php version was too old.

I then tried to just use the new image, but then nothing works at all.

Is there a correct way to do this? either updating from within the container or replacing the image works for me, i just need it updated, as I eventually want to move to fpm.

These errors are showing in the log:
php too old

Steps I have tried to fix the problem:
I was unable to update php and ended up adding the surly repo so that Bullseye (which is the Debian distro that mautic’s images are/were built on. After a lot of time fiddling with it, i got php8 installed, but no matter what i do, I can’t get mautic to use it and the way I have to install php 8 seems extremely hacky.